summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-16 06:45:38 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-16 07:04:59 +0100
commite66d95524fd3257733a713d9a2ed2a1197831b1f (patch)
tree0607e455a17a961b83aaaff5dfbe00747b24a070 /dev-python/theano
parentdev-python/tabulate: Remove Python 2 (diff)
downloadgentoo-e66d95524fd3257733a713d9a2ed2a1197831b1f.tar.gz
gentoo-e66d95524fd3257733a713d9a2ed2a1197831b1f.tar.bz2
gentoo-e66d95524fd3257733a713d9a2ed2a1197831b1f.zip
dev-python/theano: Remove Python 2 from 1.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/theano')
-rw-r--r--dev-python/theano/theano-1.0.4.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/theano/theano-1.0.4.ebuild b/dev-python/theano/theano-1.0.4.ebuild
index 68db6a25ddc7..6b6457147cc1 100644
--- a/dev-python/theano/theano-1.0.4.ebuild
+++ b/dev-python/theano/theano-1.0.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1 eutils
@@ -25,10 +25,10 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
)"
S="${WORKDIR}/${PN^}-${PV}"
@@ -36,7 +36,7 @@ S="${WORKDIR}/${PN^}-${PV}"
python_prepare_all() {
# remove bundled six
find -type f -name "*.py" -exec \
- sed -e 's:theano.compat.six:six:g' -i '{}' + || die
+ sed -e 's:theano.compat.six:six:g' -i '{}' + || die
distutils-r1_python_prepare_all
}