summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-28 08:40:05 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-28 09:08:58 +0200
commit7b0f88c6bbea13bd2c3b3344f3c9bb4680f6d41e (patch)
tree6eb578013fc4ca96f4423ca7797ccaccd291298f /dev-python/tomlkit
parentdev-python/findimports: Bump to 2.3.0 (diff)
downloadgentoo-7b0f88c6bbea13bd2c3b3344f3c9bb4680f6d41e.tar.gz
gentoo-7b0f88c6bbea13bd2c3b3344f3c9bb4680f6d41e.tar.bz2
gentoo-7b0f88c6bbea13bd2c3b3344f3c9bb4680f6d41e.zip
dev-python/tomlkit: Bump to 0.11.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomlkit')
-rw-r--r--dev-python/tomlkit/Manifest1
-rw-r--r--dev-python/tomlkit/tomlkit-0.11.6.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index 0a9804ad75ca..9adf6f4c3d93 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1,2 +1,3 @@
DIST tomlkit-0.11.4.tar.gz 187608 BLAKE2B f6920eb53c4b5dc13afd5ccd8b9ac5ae867e4b353e6bcc2be4d5e4d8774e2869f93f4c222931b2b3c505371b8812de5ef1797891ce828889a806e665ab32aa84 SHA512 b68b5d2c5f2ad7aa2cbeac308008467f22c0c9975862506bcabbfdf1de677dbaab1c5cead17c68f4bf2977a7077ddcc46ef6383bd8a87e2ac1252641ae463335
DIST tomlkit-0.11.5.tar.gz 188079 BLAKE2B 5ef55255904d3393c5a0937b6df30d95c9a41892848abaafab844233bfe9c656cdf4348a468cf2c9afa912d14a334874ac7854a9e94a4ee9b0bab35021d18667 SHA512 71225787e3543f995358b288bf459256632a8cd72a52aae2a1c6ea04e7c0978fb9ccfa856fa5e96e6d6c9d416abcefccec3e94985421ea14e31a755ee85a3dec
+DIST tomlkit-0.11.6.tar.gz 188290 BLAKE2B c0fc64177dff2254ab4d377f15bada1093e69ed66f815b04f698359f096b123b256949e871344276e6fcda26e43ac22c505460c4f906505ea9676774cbfb0c5f SHA512 692f2facb18440609b63995f690f4ba29e82d696f5ce612f872499b4a42bb0ab33fcbf52abf36057c25448b3e29f30955dbc7e0ba34f10d21cb9b5d36e9ad9bf
diff --git a/dev-python/tomlkit/tomlkit-0.11.6.ebuild b/dev-python/tomlkit/tomlkit-0.11.6.ebuild
new file mode 100644
index 000000000000..8f575bb2866a
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.11.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="
+ https://github.com/sdispater/tomlkit/
+ https://pypi.org/project/tomlkit/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # use setup.py to avoid circular dep with poetry-core
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["setuptools"]
+ build-backend = "setuptools.build_meta"
+ EOF
+}