summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-28 20:03:23 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-28 20:32:56 +0200
commitf5a60f8fa487882252c2535b95978fbf7615d938 (patch)
tree182bb66d44bdfe395ca841c8527fe2a197cefc5e /dev-python/tomlkit
parentdev-python/pytest-mock: Bump to 3.9.0 (diff)
downloadgentoo-f5a60f8fa487882252c2535b95978fbf7615d938.tar.gz
gentoo-f5a60f8fa487882252c2535b95978fbf7615d938.tar.bz2
gentoo-f5a60f8fa487882252c2535b95978fbf7615d938.zip
dev-python/tomlkit: Bump to 0.11.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomlkit')
-rw-r--r--dev-python/tomlkit/Manifest1
-rw-r--r--dev-python/tomlkit/tomlkit-0.11.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index e0e48999b611..0a9804ad75ca 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1 +1,2 @@
DIST tomlkit-0.11.4.tar.gz 187608 BLAKE2B f6920eb53c4b5dc13afd5ccd8b9ac5ae867e4b353e6bcc2be4d5e4d8774e2869f93f4c222931b2b3c505371b8812de5ef1797891ce828889a806e665ab32aa84 SHA512 b68b5d2c5f2ad7aa2cbeac308008467f22c0c9975862506bcabbfdf1de677dbaab1c5cead17c68f4bf2977a7077ddcc46ef6383bd8a87e2ac1252641ae463335
+DIST tomlkit-0.11.5.tar.gz 188079 BLAKE2B 5ef55255904d3393c5a0937b6df30d95c9a41892848abaafab844233bfe9c656cdf4348a468cf2c9afa912d14a334874ac7854a9e94a4ee9b0bab35021d18667 SHA512 71225787e3543f995358b288bf459256632a8cd72a52aae2a1c6ea04e7c0978fb9ccfa856fa5e96e6d6c9d416abcefccec3e94985421ea14e31a755ee85a3dec
diff --git a/dev-python/tomlkit/tomlkit-0.11.5.ebuild b/dev-python/tomlkit/tomlkit-0.11.5.ebuild
new file mode 100644
index 000000000000..8f575bb2866a
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.11.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="
+ https://github.com/sdispater/tomlkit/
+ https://pypi.org/project/tomlkit/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # use setup.py to avoid circular dep with poetry-core
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["setuptools"]
+ build-backend = "setuptools.build_meta"
+ EOF
+}