summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-24 03:55:34 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-24 03:58:25 -0400
commit391d63d3f758203df338f1a00d7eb4292ec87f57 (patch)
treec8a79ebbc35dab0b7eab4e6e88f7bb1ee8a3904b /dev-python/tqdm
parentdev-python/pkginfo: version bump to 1.4.2 (diff)
downloadgentoo-391d63d3f758203df338f1a00d7eb4292ec87f57.tar.gz
gentoo-391d63d3f758203df338f1a00d7eb4292ec87f57.tar.bz2
gentoo-391d63d3f758203df338f1a00d7eb4292ec87f57.zip
dev-python/tqdm: version bump to 4.19.8
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.19.8.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index e959813b41b9..98bd94ba0054 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,3 +1,4 @@
DIST tqdm-4.10.0.tar.gz 615329 BLAKE2B 59cc8db43281a22cabfb895f81c3b6f3cf4e62e67e725ae0a7137497337fea492787f7154e99fa3601f39c1b2e4ddafa5911b6a80ebac6e4e4e7f3c6575d09d5 SHA512 5c7719e13f57cf7f42e81e2514ae4db5cf72b010ead25aa8bcd4ad0037e0a374bf353c15f43f4b64337142f3c2562b952b5e18aea70634c9b11d6b82af51546e
DIST tqdm-4.19.4.tar.gz 72037 BLAKE2B 5f2ed14b6f72f16e141dd47d30559e694398420de97b7bea67e6cc10b75288a3829f206fe4b8e7965a95cb93a7bd2d70a073c35a310b0e94eca68600d0cf67b1 SHA512 56d1f2cd8f7a56964611f0399c6f8f6c64740428e38ebde6778397340b57787a3409de2755269c1a26db38cd85ddf3c90636a36d742eb2b51d8736e5ad6c5989
+DIST tqdm-4.19.8.tar.gz 73140 BLAKE2B 05147ed8458233808d30b8548b8b46fba0cd8ff117e085677418060a286e99ca5d6970e1dfd8e3206d1a95502f46afb27b528cc635ed98491f28668443184d86 SHA512 b375971384fba11ef8b73a504f1415795244324f2ba3e2fe9c5fdf4c367f070c0026e97bbb546c7bb20badd00a9755b910f3992fe4baf21365c162b7f3e48ecd
DIST tqdm-4.8.4.tar.gz 609527 BLAKE2B 3c7265f0c2f09c39a0e7d5061e8f1f12557b8e2e5b24fcbf6e8b32c596c23d04f4b940a69f35eb3ad358e232ec4a086876f605ee86bbdd487ea2714a4f53c811 SHA512 21a43e1cdfae5ce9c1db386043391c0d32f0d0ce7b3337054296cfffbbc68a57deef77efd597a0be6805023052e84724649cb29116fd8614a21a2f28440a5889
diff --git a/dev-python/tqdm/tqdm-4.19.8.ebuild b/dev-python/tqdm/tqdm-4.19.8.ebuild
new file mode 100644
index 000000000000..fd3e7a7aba04
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.19.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+SRC_URI="https://github.com/tqdm/tqdm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s#man/man1#share/man/man1#" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}