summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-13 15:27:07 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-13 15:27:07 +0100
commit9fd595a2608d2e86eda4389d72b54d7cb188c1f6 (patch)
tree4a956a0603f5afb54a4df3172caee4ec28591b8a /dev-python/transitions/transitions-0.8.7.ebuild
parentapp-arch/tar: Bump to version 1.34 (diff)
downloadgentoo-9fd595a2608d2e86eda4389d72b54d7cb188c1f6.tar.gz
gentoo-9fd595a2608d2e86eda4389d72b54d7cb188c1f6.tar.bz2
gentoo-9fd595a2608d2e86eda4389d72b54d7cb188c1f6.zip
dev-python/transitions: Bump to 0.8.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/transitions/transitions-0.8.7.ebuild')
-rw-r--r--dev-python/transitions/transitions-0.8.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/transitions/transitions-0.8.7.ebuild b/dev-python/transitions/transitions-0.8.7.ebuild
new file mode 100644
index 000000000000..baacbad3ee0a
--- /dev/null
+++ b/dev-python/transitions/transitions-0.8.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
+HOMEPAGE="https://github.com/pytransitions/transitions"
+SRC_URI="https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ || (
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ )
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/dill[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ use examples && dodoc examples/*.ipynb
+}