summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-08 00:40:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-08 01:11:22 +0200
commit87b54613f00ee435b3a4dce17eebcb1ca350c985 (patch)
treede53bab59fcd2ac31967159d1c336155ad9bb362 /dev-python/transitions
parentdev-python/pikepdf: Bump to 2.11.0 (diff)
downloadgentoo-87b54613f00ee435b3a4dce17eebcb1ca350c985.tar.gz
gentoo-87b54613f00ee435b3a4dce17eebcb1ca350c985.tar.bz2
gentoo-87b54613f00ee435b3a4dce17eebcb1ca350c985.zip
dev-python/transitions: Bump to 0.8.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/transitions')
-rw-r--r--dev-python/transitions/Manifest1
-rw-r--r--dev-python/transitions/transitions-0.8.8.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/transitions/Manifest b/dev-python/transitions/Manifest
index 7ce3d7c54048..3fb55b6ed306 100644
--- a/dev-python/transitions/Manifest
+++ b/dev-python/transitions/Manifest
@@ -1 +1,2 @@
DIST transitions-0.8.7.tar.gz 1094059 BLAKE2B f8a524751567e450818e8e1219af661661985ead8014a060fcde2af5b7c16b3d2d87140804a85cb92d003682aa237de81865336f011f0b46805ba3d2839cf415 SHA512 0a7300a38facf46fe999f53114dc42040ee6aa423f08e378727d0e083a543d1246cb83ca08a861d4e598560e55124905808649e25e57a6002bd12992ba91dc8d
+DIST transitions-0.8.8.tar.gz 1100609 BLAKE2B 18ebbb1d45e33e7933208b043b56dca40e8dcda936ffc2af4c38ad9325f3e19c0d3c9a35e4d728be05b97feb47eb922fd48317018761bc5c3243887d2f077e33 SHA512 ff6c039ed5ce9fe484c3469d2aee791010a99af7a9bc8777842f1514d7eca3fd7714694240cb57839754367c58228d59b41a88f12c2b7d75353f75e63768160d
diff --git a/dev-python/transitions/transitions-0.8.8.ebuild b/dev-python/transitions/transitions-0.8.8.ebuild
new file mode 100644
index 000000000000..baacbad3ee0a
--- /dev/null
+++ b/dev-python/transitions/transitions-0.8.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
+HOMEPAGE="https://github.com/pytransitions/transitions"
+SRC_URI="https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ || (
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ )
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/dill[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ use examples && dodoc examples/*.ipynb
+}