summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-03 09:14:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-03 10:09:15 +0100
commit3862d998573d362e213307bdf61241c4b2fe4dc9 (patch)
tree343b6f801ad0856b5bcb1c80b12731446a1d9193 /dev-python/trove-classifiers/trove-classifiers-2022.12.1.ebuild
parentdev-python/pytest-testinfra: Bump to 7.0.0 (diff)
downloadgentoo-3862d998573d362e213307bdf61241c4b2fe4dc9.tar.gz
gentoo-3862d998573d362e213307bdf61241c4b2fe4dc9.tar.bz2
gentoo-3862d998573d362e213307bdf61241c4b2fe4dc9.zip
dev-python/trove-classifiers: Bump to 2022.12.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trove-classifiers/trove-classifiers-2022.12.1.ebuild')
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2022.12.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/trove-classifiers-2022.12.1.ebuild b/dev-python/trove-classifiers/trove-classifiers-2022.12.1.ebuild
new file mode 100644
index 000000000000..964617661415
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2022.12.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+SRC_URI="
+ https://github.com/pypa/trove-classifiers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}