summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-07-11 16:25:10 -0700
committerMatt Turner <mattst88@gentoo.org>2019-07-11 22:40:19 -0700
commit7cf28b9f1d6911b9c3f9a7052555dd356f78dd1e (patch)
tree71481857c16171c75bc4d122408938df9569ab96 /dev-python/ttystatus/ttystatus-0.36.ebuild
parentdev-python/cliapp: Version bump to 1.20180812.1 (diff)
downloadgentoo-7cf28b9f1d6911b9c3f9a7052555dd356f78dd1e.tar.gz
gentoo-7cf28b9f1d6911b9c3f9a7052555dd356f78dd1e.tar.bz2
gentoo-7cf28b9f1d6911b9c3f9a7052555dd356f78dd1e.zip
dev-python/ttystatus: Version bump to 0.36
A bunch of things too: - Port to EAPI=7 - Add Python 3 compatibility - Fix incorrect license - HTTPS homepage - Depend on dev-lang/python with USE[ncurses] Closes: https://bugs.gentoo.org/605934 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/ttystatus/ttystatus-0.36.ebuild')
-rw-r--r--dev-python/ttystatus/ttystatus-0.36.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/ttystatus/ttystatus-0.36.ebuild b/dev-python/ttystatus/ttystatus-0.36.ebuild
new file mode 100644
index 000000000000..6251a3e1cb9b
--- /dev/null
+++ b/dev-python/ttystatus/ttystatus-0.36.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="Terminal progress bar and status output for command line"
+HOMEPAGE="https://liw.fi/ttystatus/"
+SRC_URI="http://git.liw.fi/${PN}/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v -p '*_tests.py' || die
+}