summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-25 15:23:23 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-25 15:29:11 +0100
commite540e39ba446bbbc7f06857f1202bbf04c8f84b6 (patch)
tree2ffc7fabfc2b65d6aac7cb2c89550d65d3d720ad /dev-python/twine/twine-3.2.0.ebuild
parentdev-python/tqdm: Remove old (diff)
downloadgentoo-e540e39ba446bbbc7f06857f1202bbf04c8f84b6.tar.gz
gentoo-e540e39ba446bbbc7f06857f1202bbf04c8f84b6.tar.bz2
gentoo-e540e39ba446bbbc7f06857f1202bbf04c8f84b6.zip
dev-python/twine: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/twine/twine-3.2.0.ebuild')
-rw-r--r--dev-python/twine/twine-3.2.0.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/twine/twine-3.2.0.ebuild b/dev-python/twine/twine-3.2.0.ebuild
deleted file mode 100644
index a4ec13e3cc3c..000000000000
--- a/dev-python/twine/twine-3.2.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of utilities for publishing packages on PyPI"
-HOMEPAGE="https://twine.readthedocs.io/ https://github.com/pypa/twine https://pypi.org/project/twine/"
-SRC_URI="https://github.com/pypa/twine/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- dev-python/jaraco-envs[${PYTHON_USEDEP}]
- dev-python/jaraco-functools[${PYTHON_USEDEP}]
- dev-python/munch[${PYTHON_USEDEP}]
- dev-python/portend[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pypiserver[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- >=dev-python/tqdm-4.14[${PYTHON_USEDEP}]
- >=dev-python/pkginfo-1.4.2[${PYTHON_USEDEP}]
- >=dev-python/readme_renderer-21.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_{6,7} pypy{,3})
- >=dev-python/keyring-15.1[${PYTHON_USEDEP}]
- >=dev-python/rfc3986-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- # avoid a setuptools_scm dependency
- sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
- sed -r -i "s:setuptools(_|-)scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+|)[[:space:]]*::" \
- setup.cfg || die
-
- # requires internet
- sed -e 's:test_check_status_code_for_wrong_repo_url:_&:' \
- -i tests/test_upload.py || die
- rm -f tests/test_integration.py || die
-
- sed -i -e '/--cov/d' pytest.ini || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}