summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-02-08 21:54:25 -0500
committerMike Gilbert <floppym@gentoo.org>2021-02-09 12:44:57 -0500
commitdeacc5bbcf72a2357bb35bb077acf65b4e6df13c (patch)
tree45c1ee5bcc4fdd69175bcc08279f044a90d40c10 /dev-python/urllib3
parentdev-python/requests: drop dependency on cryptography (diff)
downloadgentoo-deacc5bbcf72a2357bb35bb077acf65b4e6df13c.tar.gz
gentoo-deacc5bbcf72a2357bb35bb077acf65b4e6df13c.tar.bz2
gentoo-deacc5bbcf72a2357bb35bb077acf65b4e6df13c.zip
dev-python/urllib3: drop 'secure' dependencies
These deps were only needed to support older versions of python. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/urllib3-1.26.3-r1.ebuild (renamed from dev-python/urllib3/urllib3-1.26.3.ebuild)7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/urllib3/urllib3-1.26.3.ebuild b/dev-python/urllib3/urllib3-1.26.3-r1.ebuild
index b7c18f9f80b..4917ce1c828 100644
--- a/dev-python/urllib3/urllib3-1.26.3.ebuild
+++ b/dev-python/urllib3/urllib3-1.26.3-r1.ebuild
@@ -18,13 +18,12 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~
IUSE="brotli test"
RESTRICT="!test? ( test )"
+# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
+# dependencies. Do not add them to RDEPEND. They should be unnecessary with
+# modern versions of python (>= 3.2).
RDEPEND="
>=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
<dev-python/PySocks-2.0[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
- >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
- >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
"
BDEPEND="