summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-26 16:27:37 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-26 17:26:30 +0200
commit38edd4ed0651e80808006ec4b9c236f53518a8f7 (patch)
treec20d1e457f2a50ebeccdadab25191ff3fdd5975f /dev-python/whelk
parentdev-python/pyspf: Tested on py3.5 & py3.6 (diff)
downloadgentoo-38edd4ed0651e80808006ec4b9c236f53518a8f7.tar.gz
gentoo-38edd4ed0651e80808006ec4b9c236f53518a8f7.tar.bz2
gentoo-38edd4ed0651e80808006ec4b9c236f53518a8f7.zip
dev-python/whelk: Enable tests
Diffstat (limited to 'dev-python/whelk')
-rw-r--r--dev-python/whelk/whelk-2.7.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/whelk/whelk-2.7.ebuild b/dev-python/whelk/whelk-2.7.ebuild
index 71e95a04ed85..0344e53e72ba 100644
--- a/dev-python/whelk/whelk-2.7.ebuild
+++ b/dev-python/whelk/whelk-2.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,3 +18,7 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Tests fail with ${EPYTHON}"
+}