summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-29 14:02:11 +0200
committerMichał Górny <mgorny@gentoo.org>2020-03-29 14:03:11 +0200
commita3df3a493f39c8eaf8aad03366e35917e36c101d (patch)
treed71b358fd68ddda254f68ec89db46c32d99d307a /dev-python/wtforms/wtforms-2.1.ebuild
parentdev-python/wstools: Remove redundant versions (diff)
downloadgentoo-a3df3a493f39c8eaf8aad03366e35917e36c101d.tar.gz
gentoo-a3df3a493f39c8eaf8aad03366e35917e36c101d.tar.bz2
gentoo-a3df3a493f39c8eaf8aad03366e35917e36c101d.zip
dev-python/wtforms: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wtforms/wtforms-2.1.ebuild')
-rw-r--r--dev-python/wtforms/wtforms-2.1.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/wtforms/wtforms-2.1.ebuild b/dev-python/wtforms/wtforms-2.1.ebuild
deleted file mode 100644
index cae6eb2f1e90..000000000000
--- a/dev-python/wtforms/wtforms-2.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-MY_PN="WTForms"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flexible forms validation and rendering library for python web development"
-HOMEPAGE="https://wtforms.readthedocs.io/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${MY_P}"
-
-RDEPEND="
- app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- test? (
- dev-python/Babel[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # Extension-tests are written for an older version of Django
- sed \
- -e "s|'ext_django.tests', ||" \
- -i tests/runtests.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}