summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-15 01:23:24 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-15 01:23:24 -0500
commit7aeef0da81856fa42c4fffe1d39d041fb182e3fd (patch)
tree4b0837dec6d8a12062c99ff63ba6aab0b9b822e0 /dev-python/yaql
parentdev-python/python-vitrageclient: 4.1.1 bump (diff)
downloadgentoo-7aeef0da81856fa42c4fffe1d39d041fb182e3fd.tar.gz
gentoo-7aeef0da81856fa42c4fffe1d39d041fb182e3fd.tar.bz2
gentoo-7aeef0da81856fa42c4fffe1d39d041fb182e3fd.zip
dev-python/yaql: add DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/747238 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/yaql')
-rw-r--r--dev-python/yaql/yaql-1.1.3.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-python/yaql/yaql-1.1.3.ebuild b/dev-python/yaql/yaql-1.1.3.ebuild
index 5e2d7e972e02..4ed4e3dfa5bd 100644
--- a/dev-python/yaql/yaql-1.1.3.ebuild
+++ b/dev-python/yaql/yaql-1.1.3.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -15,12 +16,8 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
IUSE=""
-CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
-RDEPEND="
- ${CDEPEND}
+DEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]
>=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
dev-python/ply[${PYTHON_USEDEP}]