summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-01 09:45:31 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-01 11:06:48 +0100
commit498ff4d4ccdf1f399460752a2d3fba179e86ece3 (patch)
treee516c21ff0d9bdd2feb9607ea02dbb6717df498e /dev-python/zeroconf
parentdev-python/identify: Bump to 2.4.7 (diff)
downloadgentoo-498ff4d4ccdf1f399460752a2d3fba179e86ece3.tar.gz
gentoo-498ff4d4ccdf1f399460752a2d3fba179e86ece3.tar.bz2
gentoo-498ff4d4ccdf1f399460752a2d3fba179e86ece3.zip
dev-python/zeroconf: Bump to 0.38.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.38.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 651f3c262b0a..e98d79115eb9 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1 +1,2 @@
DIST python-zeroconf-0.38.1.gh.tar.gz 133094 BLAKE2B dae802e19b8b9488fc71cf482578be53c99bbb58580de987522e068b8d4042ac093225035bf5f7c2318c9a90bf5404e42f315cae095b0b4455ebd769facdcd81 SHA512 c60f03100c83e9327a910ad84aec768fb890453c21f9baf0fbbec96f0077c602c5e806e8a6047b87108f6d257942305a2ce76c984935ed3c000d83d2c44bb8d6
+DIST python-zeroconf-0.38.3.gh.tar.gz 133187 BLAKE2B 2058a4e8b772b49e1e6c3dd55ca1ef1f73630724d22a253d7f14f63a361e58cff24a700dfdeeaac5ca1bed43490865885dbd8956ee58924b4f9b0c4ae3351131 SHA512 30adeb1d2dfb317224a78a7f23b64da6449b9f2e64bfebf6155711f65fb302327cb78c98afd646ae167f1fbda41b8a6c927f0d36278d266583bc5369af70f8e5
diff --git a/dev-python/zeroconf/zeroconf-0.38.3.ebuild b/dev-python/zeroconf/zeroconf-0.38.3.ebuild
new file mode 100644
index 000000000000..267b91fb5e94
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.38.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+)