summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-07 05:43:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-07 06:19:00 +0200
commita9775c9062376d0dc8d09e8259af49c1162cf2d4 (patch)
tree25cbb03add3769205f46dac84515c4173332036e /dev-python/zeroconf
parentdev-python/ypy-websocket: Bump to 0.9.0 (diff)
downloadgentoo-a9775c9062376d0dc8d09e8259af49c1162cf2d4.tar.gz
gentoo-a9775c9062376d0dc8d09e8259af49c1162cf2d4.tar.bz2
gentoo-a9775c9062376d0dc8d09e8259af49c1162cf2d4.zip
dev-python/zeroconf: Bump to 0.55.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.55.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index b8399346c0f7..0021d740cf48 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -3,3 +3,4 @@ DIST python-zeroconf-0.47.4.gh.tar.gz 151640 BLAKE2B 4591135e81fc0c1c22444fb8823
DIST python-zeroconf-0.51.0.gh.tar.gz 152236 BLAKE2B 2339bd47e4f8abecb5b56c722e275c0cef63d4ab389c58b9a50e22e2a450b527f11727615a9c61e6e23d275195353121c5697f2fd496fbf9370465db5d9258c8 SHA512 e62d74ce164cd92913382e5a5530e2732a739e065f3f2fa7bc5cc7f62e863c98e8979ab08f5527f301e833cd1107c2d1c412db1dfafbf2bd1546b6e197d2c43a
DIST zeroconf-0.53.0.tar.gz 138658 BLAKE2B 9a0af4a08a51d8b39d6eac30a1ad92d5e7c14bdaa3a7d8b57b3664c91c0c740af6f08c3bbe1d5ffb4a950e4cc1bec12b9426b595f76232d48510dd5df25c1b57 SHA512 9309b385a1acdcdb7d2812e0b554373fc2a5324f804636cf32449aa158ac629387f670c1770bce5e11245f9e482a6bb379f7e3cbf935a1977fca8158181163d5
DIST zeroconf-0.54.0.tar.gz 139937 BLAKE2B ef8e8ad309a73bd725ad1aa8af54dd14d338f68c5f23643a45cd88a2e8ec8a64b6c589ec0d00a341769003e858554da0edac49722d81c92ec36638cfe4d8d0e2 SHA512 ac2f2c76e8d551102919ae27dcbcdaea80e4ec1b0514edab7d9776feb20466933669590af5f9de90395df909c371a6d30cc086daa8861464ba51f2aafd3a0592
+DIST zeroconf-0.55.0.tar.gz 140032 BLAKE2B 02de3a67e687d2fca36983fcabb1a781c81b2bd67f58497d9e1c847c0411987303dc5a20133dfa5332e660a59c27264001d884248996964e1706703c08b2df15 SHA512 79e263828d66f5110837e3a38eec595375fcd4b7f07272e1f22c00970b343781064ebcf6faf3f488c8326b6e455359ef53f990c9152149520bea5f1dee4c834d
diff --git a/dev-python/zeroconf/zeroconf-0.55.0.ebuild b/dev-python/zeroconf/zeroconf-0.55.0.ebuild
new file mode 100644
index 000000000000..18c772b8a425
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.55.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}