summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-03 08:33:37 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-03 08:33:37 +0200
commit6fbbb91a29b8fe5436dc6e87543f74dd08e6514f (patch)
tree5872819e342afa7a3cd5c7f5032fa65881e2d393 /dev-python/zipp
parentdev-python/ipdb: Remove old (diff)
downloadgentoo-6fbbb91a29b8fe5436dc6e87543f74dd08e6514f.tar.gz
gentoo-6fbbb91a29b8fe5436dc6e87543f74dd08e6514f.tar.bz2
gentoo-6fbbb91a29b8fe5436dc6e87543f74dd08e6514f.zip
dev-python/zipp: Bump to 3.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.5.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index a0af4c9ace85..823621fdc50e 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1 +1,2 @@
DIST zipp-3.4.1.tar.gz 16545 BLAKE2B 5ebdc4d1e932d72502866701db8b0f352aca3194890d9ed340722bb2a65c4e3be0f6bb54f49567e4fd46faaec3379d0c1d668e1a55f63bea6c57e4ef0c2f9e01 SHA512 2ba50109efd0ceea9eb1d57e2d839f522b5a78a8dae344d6da54b79305dd46bff23f1116f562127290152c0b100369439c17fe9dc3fb14d0b42beaa48348ebe6
+DIST zipp-3.5.0.tar.gz 13270 BLAKE2B ba3b6f82ed0f1a902050ee8a89b6876a839d180dc048dd19cd31ddbaf89ec0494b9444f2ac082ed347e3183ccaf2e8342748737c2a29e1a2bbc492a0bc34767c SHA512 676d7e9a7fde386b57a213975121aba015461453f0809a97d39d030b06918a4c54ba1cad21877ddf007560941ae285883098d81d5e6f17eb4636379345b4513d
diff --git a/dev-python/zipp/zipp-3.5.0.ebuild b/dev-python/zipp/zipp-3.5.0.ebuild
new file mode 100644
index 000000000000..4ceef32cedf6
--- /dev/null
+++ b/dev-python/zipp/zipp-3.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.2[${PYTHON_USEDEP}]
+ test? ( dev-python/jaraco-itertools[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Skip a potentially flaky performance test
+ sed -i -e '/^import func_timeout\|^ *@func_timeout\.func_set_timeout/d' \
+ -e 's/test_implied_dirs_performance/_&/' test_zipp.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Ignoring zipp.py from ${S} avoids ImportPathMismatchError with Python < 3.8
+ # by ensuring only zipp from ${BUILD_DIR} is loaded
+ epytest --ignore zipp.py
+}