summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-12-10 21:31:08 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-12-10 21:48:36 -0600
commit5324eab0001f715a8f01a2e087c624e2cb3bd8a6 (patch)
tree590241cd375d4b9e1a8724cecf2520d8b5cb94ae /dev-python/zope-schema/zope-schema-4.5.0.ebuild
parentdev-python/flufl-bounce: 3.0 for mailman (diff)
downloadgentoo-5324eab0001f715a8f01a2e087c624e2cb3bd8a6.tar.gz
gentoo-5324eab0001f715a8f01a2e087c624e2cb3bd8a6.tar.bz2
gentoo-5324eab0001f715a8f01a2e087c624e2cb3bd8a6.zip
dev-python/zope-schema: adding for zope-configuration for mailman 3
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-python/zope-schema/zope-schema-4.5.0.ebuild')
-rw-r--r--dev-python/zope-schema/zope-schema-4.5.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/zope-schema/zope-schema-4.5.0.ebuild b/dev-python/zope-schema/zope-schema-4.5.0.ebuild
new file mode 100644
index 000000000000..a56c75eb8fb5
--- /dev/null
+++ b/dev-python/zope-schema/zope-schema-4.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit distutils-r1
+MY_PN=zope.schema
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope schema Architecture"
+HOMEPAGE="https://github.com/zopefoundation/zope.schema http://docs.zope.org/zope.schema/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}