summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-23 11:55:07 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-31 13:46:55 +0200
commit2990366dbf3fe43fba228ef3d3701cd4b453346c (patch)
tree05d574207112c5c58727f4887f2bbc0b4552ae94 /dev-python/zope-testrunner/zope-testrunner-5.3.0.ebuild
parentdev-python/zope-i18nmessageid: bump to python 3.10 (diff)
downloadgentoo-2990366dbf3fe43fba228ef3d3701cd4b453346c.tar.gz
gentoo-2990366dbf3fe43fba228ef3d3701cd4b453346c.tar.bz2
gentoo-2990366dbf3fe43fba228ef3d3701cd4b453346c.zip
dev-python/zope-testrunner: bump to python 3.10
fix tests for python3.10 passes tests Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zope-testrunner/zope-testrunner-5.3.0.ebuild')
-rw-r--r--dev-python/zope-testrunner/zope-testrunner-5.3.0.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/zope-testrunner/zope-testrunner-5.3.0.ebuild b/dev-python/zope-testrunner/zope-testrunner-5.3.0.ebuild
index 07f992c4b75a..1142107a76cd 100644
--- a/dev-python/zope-testrunner/zope-testrunner-5.3.0.ebuild
+++ b/dev-python/zope-testrunner/zope-testrunner-5.3.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -20,13 +20,17 @@ LICENSE="ZPL"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-BDEPEND="
- test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
RDEPEND="
dev-python/namespace-zope[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/zope-exceptions[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-test-py3.10.patch"
+)
distutils_enable_tests setup.py