summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2015-12-29 15:49:40 +0100
committerIan Delaney <idella4@gentoo.org>2015-12-29 23:16:07 +0800
commit06337640cc3c5f53ab40f568e29600fdfd7abfd1 (patch)
tree9146639603a8807f18c8b3c7ca4b7ebf08f839c7 /dev-python
parentapp-backup/bareos: remove old version (diff)
downloadgentoo-06337640cc3c5f53ab40f568e29600fdfd7abfd1.tar.gz
gentoo-06337640cc3c5f53ab40f568e29600fdfd7abfd1.tar.bz2
gentoo-06337640cc3c5f53ab40f568e29600fdfd7abfd1.zip
dev-python/jaraco-logging: needed as a new dep to dev-python/irc
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jaraco-logging/Manifest1
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-1.3.1.ebuild44
-rw-r--r--dev-python/jaraco-logging/metadata.xml14
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/jaraco-logging/Manifest b/dev-python/jaraco-logging/Manifest
new file mode 100644
index 000000000000..8fde3b136774
--- /dev/null
+++ b/dev-python/jaraco-logging/Manifest
@@ -0,0 +1 @@
+DIST jaraco.logging-1.3.1.tar.gz 4589 SHA256 e80e43a7b0d94bda2faacc1b996d5cc8bc6dcf20205048d18f4889f35e956580 SHA512 aaa2b29551a13358887e0747acb47ca2a6611ce1bfb08259bc70c7908929c4d2c45eefd7738e808b7b2404d723425efd69f9cb9601e0fb0c08f611bcf744ceae WHIRLPOOL 150101a7fa0b50a0130802638bd73124543c1836c27a96deb21be4eb6966028d58e4cabc6513a7149d08273a728ac1e46a27f78b6a139e304b16f14d2227abf3
diff --git a/dev-python/jaraco-logging/jaraco-logging-1.3.1.ebuild b/dev-python/jaraco-logging/jaraco-logging-1.3.1.ebuild
new file mode 100644
index 000000000000..90846bd57c1a
--- /dev/null
+++ b/dev-python/jaraco-logging/jaraco-logging-1.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
+HOMEPAGE="https://github.com/jaraco/jaraco.logging"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/tempora[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ if use test && has_version "${CATEGORY}/${PN}"; then
+ die "Ensure $PN is not already installed or the test suite will fail"
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/jaraco-logging/metadata.xml b/dev-python/jaraco-logging/metadata.xml
new file mode 100644
index 000000000000..3c58c004f954
--- /dev/null
+++ b/dev-python/jaraco-logging/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">jaraco.logging</remote-id>
+ <remote-id type="github">jaraco/jaraco.logging</remote-id>
+ </upstream>
+</pkgmetadata>