summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-14 09:51:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-14 10:14:20 +0200
commit0bf3aa0ace7de048708732f5d25bfc8b9de370dd (patch)
treef0d30d20f00c13b7916ee89025ae0faf0a5e7831 /dev-python
parentdev-python/Faker: Bump to 8.1.4 (diff)
downloadgentoo-0bf3aa0ace7de048708732f5d25bfc8b9de370dd.tar.gz
gentoo-0bf3aa0ace7de048708732f5d25bfc8b9de370dd.tar.bz2
gentoo-0bf3aa0ace7de048708732f5d25bfc8b9de370dd.zip
dev-python/fonttools: Bump to 4.23.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.23.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 6d9412e77785..b7a2989583c1 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,2 +1,3 @@
DIST fonttools-4.22.0.tar.gz 2544600 BLAKE2B 685da467c40fc7cffe2b33b08da53e5bd148c5190efdc8d08e2c66ef06e67b5e26ec5fa090334b9ef427b1a005c6386b0f78b978d376c7daee7f4d540faa21c7 SHA512 06db054ce488d0291f876b05b5dd09a772a702f1d45b97c1ba46d02e01fe59f7c63e268fff958baa4076c1ce72f450384e473263250c1617791d78c0e311710d
DIST fonttools-4.22.1.tar.gz 2544433 BLAKE2B 711737f696bd3a25f0c0eec2c1fb80c38dcab81d974c7f5c9d9e644aa3850dbb08502ba14111397b42615fc5287f9af8aa4d7b83e7fe9f23ae4d080f2864189d SHA512 2f38eda41ce913bdd6e62f495a215c38ed9c1fa7df87f1ecc0964b3065498e39c55e030899a5561321b16f995a705449c958244ecca2aaef492c49066db0ef93
+DIST fonttools-4.23.0.tar.gz 2550231 BLAKE2B 0d24921baa7a1fda0b18086fb6e86f84b0f3331d84ad2e5d0a74a75147815fc468827445c60ed2f906ce140e4b7a1ee9759a195ec208470f4bacd96e5841b4f9 SHA512 30eb416b38af6176186b45c5b771c96369b4a2fab380dc7d4c5bb11078070bf3d18ee1e82717c84c19c24098b18507120055ddefd8cb9233ed9fa81bfcd479a8
diff --git a/dev-python/fonttools/fonttools-4.23.0.ebuild b/dev-python/fonttools/fonttools-4.23.0.ebuild
new file mode 100644
index 000000000000..95ced12ecf0d
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.23.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx epytest Tests fontTools
+}