summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-12 09:44:03 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-12 10:37:01 +0200
commit11c129f64ad6b4ff4b33acd7f643cb581d03a035 (patch)
treec11fe765f8693b91be4456fbe187b67c4ac51b02 /dev-python
parentdev-python/watchdog: Enable pypy3 (diff)
downloadgentoo-11c129f64ad6b4ff4b33acd7f643cb581d03a035.tar.gz
gentoo-11c129f64ad6b4ff4b33acd7f643cb581d03a035.tar.bz2
gentoo-11c129f64ad6b4ff4b33acd7f643cb581d03a035.zip
dev-python/werkzeug: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/werkzeug/Manifest1
-rw-r--r--dev-python/werkzeug/werkzeug-2.0.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 27e0e72d79b1..05e039bb981e 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1 +1,2 @@
DIST werkzeug-1.0.1.gh.tar.gz 907482 BLAKE2B d2dcdce8b1bcbb177b52b0915f2c0ac17d235dee3c77b23e81e4b35412d1f53a194d3c7c7f2a5c065ade99797effe72cc464cf6980b12c761a8a919338021660 SHA512 ba82120fb3e96e3a1334c6452d5ba1950fc016d2d147d643bbc2168ccec496f1dea799982ae8c578167155082c0bdbda5d56a23f64b4b6865f97e90e22df022e
+DIST werkzeug-2.0.0.gh.tar.gz 894475 BLAKE2B 608de444944fa0bd35c0244a30967446abb8f0d05a8cd49f09707c368b6f9649b299f427fa7bc2e54628cf3eb688c399e420ecd54f12d7eab9cb063c7c740b07 SHA512 8c8e36a58fe53ac4ad3152a34145c726a9145782262b9d47be7bfe9a8e127666b0d0c0c50d305277a153298644732efe37e3785ceaa5b11394adfeb70d86e70d
diff --git a/dev-python/werkzeug/werkzeug-2.0.0.ebuild b/dev-python/werkzeug/werkzeug-2.0.0.ebuild
new file mode 100644
index 000000000000..62757f1d6ba7
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-2.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://werkzeug.palletsprojects.com/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug"
+SRC_URI="
+ https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+DEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:httpbin tests
+}