summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-17 16:22:17 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-17 16:22:17 -0400
commit13a092a55a4b865e423e1f5fa70cdba0919fe235 (patch)
treec96b15f6801a43bce5289afd4565f82c8ce1b343 /dev-python
parentnet-fs/samba-4.9.1-r0: add ~alpha keyword (diff)
downloadgentoo-13a092a55a4b865e423e1f5fa70cdba0919fe235.tar.gz
gentoo-13a092a55a4b865e423e1f5fa70cdba0919fe235.tar.bz2
gentoo-13a092a55a4b865e423e1f5fa70cdba0919fe235.zip
dev-python/ratelimit: drop spurious pytest-cov dep
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ratelimit/ratelimit-1.4.1.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/ratelimit/ratelimit-1.4.1.ebuild b/dev-python/ratelimit/ratelimit-1.4.1.ebuild
index 3c01b8f2c100..e91d5f08f03e 100644
--- a/dev-python/ratelimit/ratelimit-1.4.1.ebuild
+++ b/dev-python/ratelimit/ratelimit-1.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,11 +16,14 @@ KEYWORDS="~amd64 ~x86"
IUSE="test"
DEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- )"
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ default
+ # remove --cov args injection
+ rm pytest.ini || die
+}
python_test() {
- py.test || die
+ pytest || die
}