summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-12-09 19:40:32 +0100
committerMichał Górny <mgorny@gentoo.org>2015-12-09 20:06:47 +0100
commit180e66b602acd224b8d803c7e405b071a6c6782b (patch)
treeeeb8051b48c6b3acc7ef015d2f45ad012fca1b64 /dev-python
parentdev-python/pycups: Restrict *_all() phases to py2 for USE=doc (diff)
downloadgentoo-180e66b602acd224b8d803c7e405b071a6c6782b.tar.gz
gentoo-180e66b602acd224b8d803c7e405b071a6c6782b.tar.bz2
gentoo-180e66b602acd224b8d803c7e405b071a6c6782b.zip
dev-python/suds: Restrict *_all() to python2 when USE=doc
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/suds/suds-0.6-r1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/suds/suds-0.6-r1.ebuild b/dev-python/suds/suds-0.6-r1.ebuild
index e9c939752ec1..b99f3b046b91 100644
--- a/dev-python/suds/suds-0.6-r1.ebuild
+++ b/dev-python/suds/suds-0.6-r1.ebuild
@@ -27,6 +27,10 @@ RDEPEND=""
DOCS=( README.rst notes/{argument_parsing.rst,readme.txt,traversing_client_data.rst} )
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
+}
+
python_compile_all() {
# to say that it's both, because it kinda is...
! use doc || epydoc -n "Suds - ${DESCRIPTION}" -o doc suds || die