summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-19 13:39:22 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-19 13:45:34 +0100
commit2de7b36bcc25ad41574baf85a065bdfc4a67eae2 (patch)
tree3e4b66791a3e4590c0db75868d80a3644009ba9e /dev-python
parentdev-python/pygal: Bump (diff)
downloadgentoo-2de7b36bcc25ad41574baf85a065bdfc4a67eae2.tar.gz
gentoo-2de7b36bcc25ad41574baf85a065bdfc4a67eae2.tar.bz2
gentoo-2de7b36bcc25ad41574baf85a065bdfc4a67eae2.zip
dev-python/pygresql: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygresql/Manifest1
-rw-r--r--dev-python/pygresql/pygresql-4.2.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/pygresql/Manifest b/dev-python/pygresql/Manifest
index 621f42e5e9b..37947de5af4 100644
--- a/dev-python/pygresql/Manifest
+++ b/dev-python/pygresql/Manifest
@@ -1 +1,2 @@
DIST PyGreSQL-4.1.1.tgz 100883 SHA256 bb14092f97c66ed13b8faf71471b8c156c6b46d915858447f3a63e9abe48eef7 SHA512 4b37c56f2112471aa5f3003a1d867382ce1b7510afa0963f0ceeb2f8175ca601bb5bade9ea2038d44a1041f12233e364f138a635bb7b353d0a82aeb7d9d49b7f WHIRLPOOL 323bfd1b72341be6b14d71fd4f05f5005a0f8a387f9b050ef3c786531ea19e057aa67fb5737b5aa0c4ca0912ad697a39d8957d70bb6bb4056e81f406ade5a6b9
+DIST PyGreSQL-4.2.zip 1377728 SHA256 c57adc6b76e8b513e819b8f36710cf906d21617ff6513a0c4dad4acecdfccf3c SHA512 84044480c3f25548137240ac999334546b87987ac6c601608bcae057cf93567f0eb24e343f6ee214ea87e09ac6bd5ce80cfeb5f75deb7896e87b001a2099c78f WHIRLPOOL cac5d4fed22e51316c3c8cc0de367dc5998642c1425a944b147ed059ee3f70387ac704f8465b6fdbde0802e92c21369f0171c2dc0ee2ebbc1e7f0c827b5b900d
diff --git a/dev-python/pygresql/pygresql-4.2.ebuild b/dev-python/pygresql/pygresql-4.2.ebuild
new file mode 100644
index 00000000000..91fb90dcd8e
--- /dev/null
+++ b/dev-python/pygresql/pygresql-4.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+POSTGRES_COMPAT=( 9.{0,1,2,3,4,5} )
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P="PyGreSQL-${PV}"
+
+DESCRIPTION="A Python interface for the PostgreSQL database"
+HOMEPAGE="http://www.pygresql.org/"
+SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.zip"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="|| (
+ dev-db/postgresql:9.5
+ dev-db/postgresql:9.4
+ dev-db/postgresql:9.3
+ dev-db/postgresql:9.2
+ dev-db/postgresql:9.1
+ dev-db/postgresql:9.0
+)"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+# Verify that the currently selected PostgreSQL slot is set to one of
+# the slots defined in POSTGRES_COMPAT.
+postgres_check_slot() {
+ if ! declare -p POSTGRES_COMPAT &>/dev/null; then
+ die 'POSTGRES_COMPAT not declared.'
+ fi
+
+# Don't die because we can't run postgresql-config during pretend.
+[[ "$EBUILD_PHASE" = "pretend" && -z "$(which postgresql-config 2> /dev/null)" ]] \
+ && return 0
+
+ local res=$(echo ${POSTGRES_COMPAT[@]} \
+ | grep -c $(postgresql-config show 2> /dev/null) 2> /dev/null)
+
+ if [[ "$res" -eq "0" ]] ; then
+ eerror "PostgreSQL slot must be set to one of: "
+ eerror " ${POSTGRES_COMPAT[@]}"
+ return 1
+ fi
+
+ return 0
+}
+
+pkg_pretend() {
+ postgres_check_slot
+}
+
+pkg_setup() {
+ postgres_check_slot || die
+}
+
+python_install_all() {
+ local DOCS=( docs/*.rst )
+ distutils-r1_python_install_all
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/tutorial
+ doins tutorial/*
+ dohtml docs/*.{html,css}
+ fi
+}