summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-25 01:39:31 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-25 01:41:19 +0200
commit31617d42889cfaaec2a4bfa5cabc7b552f084d16 (patch)
treeeaa4949f2012aeb148f32ea800e02fc93dfcf9e8 /dev-python
parentdev-python/inflection: add Python 3.7, more verbose tests, EAPI=7 (diff)
downloadgentoo-31617d42889cfaaec2a4bfa5cabc7b552f084d16.tar.gz
gentoo-31617d42889cfaaec2a4bfa5cabc7b552f084d16.tar.bz2
gentoo-31617d42889cfaaec2a4bfa5cabc7b552f084d16.zip
dev-python/humanize: add Python 3.7, EAPI=7
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/humanize/humanize-0.5.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/humanize/humanize-0.5.1.ebuild b/dev-python/humanize/humanize-0.5.1.ebuild
index cddd0815cf3a..a476335fd67a 100644
--- a/dev-python/humanize/humanize-0.5.1.ebuild
+++ b/dev-python/humanize/humanize-0.5.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
inherit distutils-r1
@@ -18,7 +18,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
-DEPEND="
+BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/mock[${PYTHON_USEDEP}] )