summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-21 23:26:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-21 23:28:36 +0200
commit334d47b15e237a864bae536508e86c86984f4640 (patch)
tree92f65daf649adc405f29872e6da7763a4e91789d /dev-python
parentgames-board/gnome-hearts: fix HOMEPAGE (diff)
downloadgentoo-334d47b15e237a864bae536508e86c86984f4640.tar.gz
gentoo-334d47b15e237a864bae536508e86c86984f4640.tar.bz2
gentoo-334d47b15e237a864bae536508e86c86984f4640.zip
dev-python/cached-property: Bump to 1.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cached-property/Manifest1
-rw-r--r--dev-python/cached-property/cached-property-1.5.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/cached-property/Manifest b/dev-python/cached-property/Manifest
index 747064ce7f80..a0361f4b0467 100644
--- a/dev-python/cached-property/Manifest
+++ b/dev-python/cached-property/Manifest
@@ -1 +1,2 @@
DIST cached-property-1.5.1.tar.gz 12791 BLAKE2B dcc75564d3b1dbb2f34ea433f4a477b2fe0454047f1fb4825cc6350458bf09509cf970b308744d79eb3b17f96c04c606ad36327c7e24f0b13f412880d9ad2ab7 SHA512 61bbedb48336af7c0b465421eb4d3b6b48155cfe4fd6270ff49caefe0d80e40b50c4801a68a5564931d316e374b69112ad14f72687a015ce81aaeade6fcf9ce3
+DIST cached-property-1.5.2.tar.gz 12244 BLAKE2B 26981dcfa51925741962c60ad8659a165af6d7f242f4abd392932aac20e966ad6c1763a25184bbabdeb5bd75f8063a430c41f0241afdee8013ffcb437b3ff7da SHA512 626d98a8891a70d858269859cf4e49416464c836d073c1331c21033a4cd9e0e47dc89b53bf393375439992f4993972517dc3cdcbb2cc6f8286f282d3c973e600
diff --git a/dev-python/cached-property/cached-property-1.5.2.ebuild b/dev-python/cached-property/cached-property-1.5.2.ebuild
new file mode 100644
index 000000000000..819cd6b14ebf
--- /dev/null
+++ b/dev-python/cached-property/cached-property-1.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A cached-property for decorating methods in classes"
+HOMEPAGE="https://github.com/pydanny/cached-property"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND="test? ( dev-python/freezegun[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # bug 638250
+ eapply "${FILESDIR}"/${PN}-1.5.1-test-failure.patch
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ dodoc README.rst HISTORY.rst CONTRIBUTING.rst AUTHORS.rst
+ distutils-r1_python_install_all
+}