summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-13 07:57:51 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-13 08:10:04 +0200
commit42fa42229f82a45173d9ca9095a489e7028364c4 (patch)
treeda517f0b898f335f34864e1bed588805e2ec8574 /dev-python
parentdev-python/feedparser: Bump to 6.0.3 (diff)
downloadgentoo-42fa42229f82a45173d9ca9095a489e7028364c4.tar.gz
gentoo-42fa42229f82a45173d9ca9095a489e7028364c4.tar.bz2
gentoo-42fa42229f82a45173d9ca9095a489e7028364c4.zip
dev-python/path-py: Bump to 16.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/path-py/Manifest1
-rw-r--r--dev-python/path-py/path-py-16.0.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/path-py/Manifest b/dev-python/path-py/Manifest
index bddc7e4d6140..c4cc00b9bd9c 100644
--- a/dev-python/path-py/Manifest
+++ b/dev-python/path-py/Manifest
@@ -1 +1,2 @@
DIST path-15.1.2.tar.gz 48280 BLAKE2B 6dd6be743939d4ac1edd5caab18658473d7318eaf255140198db34cfb28c95322ed8ae05284683b18a0146f412ff8a2c14dae60d018740f8bb9cfda861b8ea20 SHA512 76f2a04800154ee8c7b7b9783bf7c63c544da74bb2f92424aeb437448a04dcdec008deab262d3b40d515404e6144bbad44e618d824974654ef10676878415ba4
+DIST path-16.0.0.tar.gz 44187 BLAKE2B 839c8a9d10cf4ac3f738a9e661fbfb1059554f965fc8224457c05c249578a18118129b69b46276fe569fc8bc33b398be1462d660bb20b905ecc6ab2b4db3f8fc SHA512 3874321d488543219a081adcb692739fcc4935cddaf563b58fe5a97c2cee4b5b683b2be52d220854b2f2224d15ec2bde054a53862352c249f14f1460a72d5e72
diff --git a/dev-python/path-py/path-py-16.0.0.ebuild b/dev-python/path-py/path-py-16.0.0.ebuild
new file mode 100644
index 000000000000..05cfe7a2439c
--- /dev/null
+++ b/dev-python/path-py/path-py-16.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_P="path-${PV}"
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="https://pypi.org/project/path/ https://github.com/jaraco/path"
+SRC_URI="mirror://pypi/p/path/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ !<dev-python/pytest-shutil-1.7.0-r1
+ !<dev-python/pytest-virtualenv-1.7.0-r1"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}