summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-05-05 23:00:14 +0200
committerDavid Seifert <soap@gentoo.org>2016-05-05 23:11:07 +0200
commit4888f8608fcb56f18e82d287aa1142b2004d89a8 (patch)
tree3db167aaca663958270c140dc3a5bf08c6b15a0b /dev-python
parentdev-python/tagpy: Require USE="threads" for dev-libs/boost (diff)
downloadgentoo-4888f8608fcb56f18e82d287aa1142b2004d89a8.tar.gz
gentoo-4888f8608fcb56f18e82d287aa1142b2004d89a8.tar.bz2
gentoo-4888f8608fcb56f18e82d287aa1142b2004d89a8.zip
dev-python/tagpy: Require USE="threads" for dev-libs/boost
Gentoo-Bug: 580496 * EAPI=6 * Add python-3.5 support * Remove call to 'distutils-r1_python_configure' Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tagpy/tagpy-2013.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/tagpy/tagpy-2013.1.ebuild b/dev-python/tagpy/tagpy-2013.1.ebuild
index 3518f856a216..579986ce0e1f 100644
--- a/dev-python/tagpy/tagpy-2013.1.ebuild
+++ b/dev-python/tagpy/tagpy-2013.1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit distutils-r1
@@ -16,7 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="examples"
-RDEPEND=">=dev-libs/boost-1.49.0[python${PYTHON_TARGETS}]
+RDEPEND=">=dev-libs/boost-1.49.0:=[python,threads,${PYTHON_USEDEP}]
>=media-libs/taglib-1.7.2"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
@@ -27,7 +28,6 @@ python_configure() {
"${PYTHON}" configure.py \
--taglib-inc-dir="${EPREFIX}/usr/include/taglib" \
--boost-python-libname="boost_python-${EPYTHON#python}"
- distutils-r1_python_configure
}
python_install_all() {