summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-16 15:42:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-16 17:56:57 +0200
commit4edfca6c7b2111b778b86084e1d3be8ce44f362f (patch)
tree26f95e22116fddf084b282e75fb17ee23f9e9803 /dev-python
parentdev-python/traitlets: Drop old (diff)
downloadgentoo-4edfca6c7b2111b778b86084e1d3be8ce44f362f.tar.gz
gentoo-4edfca6c7b2111b778b86084e1d3be8ce44f362f.tar.bz2
gentoo-4edfca6c7b2111b778b86084e1d3be8ce44f362f.zip
dev-python/testpath: Drop old
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/testpath/Manifest2
-rw-r--r--dev-python/testpath/testpath-0.2.ebuild54
-rw-r--r--dev-python/testpath/testpath-0.3.ebuild54
3 files changed, 0 insertions, 110 deletions
diff --git a/dev-python/testpath/Manifest b/dev-python/testpath/Manifest
index b56b846a3334..631cb2c9ded1 100644
--- a/dev-python/testpath/Manifest
+++ b/dev-python/testpath/Manifest
@@ -1,3 +1 @@
-DIST testpath-0.2.tar.gz 13732 BLAKE2B e7a20fdbef3dff25d8e2072167d4eb078832c7b55057dbd6fa5f38dbbc3a84304eeb817b9a5294fc4215df56563906da0288ef2c349f14c9afb72ac5561337b2 SHA512 cc211bdc8f31ff4c286324e37bbce7fd84e19447d9735f396ce67f7568dd1d133be732c1fd7a08928c94566279d0f293a0caeed6a58ae6cd3dc293035fe164ea
DIST testpath-0.3.1.tar.gz 91333 BLAKE2B 86787b9677e8baa6d45fb5e6f047f2ab448e385201f20af3a3a9f33d6edd6c67e4eec09c178e815626096ad77d417ef99ddee562bf0fd7947b3f7ae1862f8156 SHA512 ab826cfb76d9a3ed6f1b178240f6bf61439bd792be26b5ad407b5c3efaa455b48965ceaf17e4ca6a4bc706465a8ed1c6c31a1572df5beeea2bb8db7814dc04f0
-DIST testpath-0.3.tar.gz 91250 BLAKE2B 88ea7ad9c67eef9aaa49e435a4d56d86b8c87818a416f3630f8d34aecd85f478aff778b1fc3c13f1ad0aafb524dc649393a73ebfb6f74dd3391548f36f1c2e4d SHA512 71a3266e17616c4df4a4c465151e9d48b89f573e4562132e85982b62446396884a270a32b5d4956aac1f0be1a00096cab9d0dc1718ae8b6312b0436eca683bdf
diff --git a/dev-python/testpath/testpath-0.2.ebuild b/dev-python/testpath/testpath-0.2.ebuild
deleted file mode 100644
index 8200f6e2480a..000000000000
--- a/dev-python/testpath/testpath-0.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Test utilities for code working with files and commands"
-HOMEPAGE="http://jupyter.org"
-SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-DEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- virtual/python-pathlib[${PYTHON_USEDEP}]
- )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- "
-
-PATCHES=(
- "${FILESDIR}/${P}"-setup.py.patch
- )
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
- }
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
- py.test || die
-}
diff --git a/dev-python/testpath/testpath-0.3.ebuild b/dev-python/testpath/testpath-0.3.ebuild
deleted file mode 100644
index efa5591fab24..000000000000
--- a/dev-python/testpath/testpath-0.3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Test utilities for code working with files and commands"
-HOMEPAGE="http://jupyter.org"
-SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc test"
-
-DEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- virtual/python-pathlib[${PYTHON_USEDEP}]
- )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- "
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.2-setup.py.patch
- )
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
- }
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
- py.test || die
-}