summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-17 09:32:09 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-17 09:32:09 +0200
commit538c378f478a29149ee668b582c78ac02f6ad0e1 (patch)
tree2b7e7ab3c33e452fba3604f9419ac84df5f9682c /dev-python
parentdev-python/cftime: Remove old (diff)
downloadgentoo-538c378f478a29149ee668b582c78ac02f6ad0e1.tar.gz
gentoo-538c378f478a29149ee668b582c78ac02f6ad0e1.tar.bz2
gentoo-538c378f478a29149ee668b582c78ac02f6ad0e1.zip
dev-python/chardet: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/chardet/Manifest1
-rw-r--r--dev-python/chardet/chardet-3.0.4-r1.ebuild28
-rw-r--r--dev-python/chardet/files/chardet-3.0.4-pytest-4.patch23
3 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/chardet/Manifest b/dev-python/chardet/Manifest
index 1fa67aa0c09c..ed73b3a9c79e 100644
--- a/dev-python/chardet/Manifest
+++ b/dev-python/chardet/Manifest
@@ -1,2 +1 @@
-DIST chardet-3.0.4.tar.gz 1872214 BLAKE2B b93e2d3e0b5a5c35affa5e3ee661323029f79837a1222d8f69db72911301d9490c9788d2effc577eeeb2a50334cc855afc4bdf4b8dbafb143fcc411d93b824a9 SHA512 b433ea0e15e200df968e6d61c671c42fbd77e519eb033035c4a5c241e1f98e1dfaea6747af632788507583b3ef85b00d510b3f6ef5cf58589ceca1b3a088b357
DIST chardet-4.0.0.tar.gz 1923933 BLAKE2B 10dce34cbe6f01536a526931510ed625bc5062335e9419e24c9e48d5697ebbe70dcc54ffaa976ec153340cc74c3086627a3b1dd9e34be32c89a9a81e83fd70d0 SHA512 cb0e052fdd9fec251ebc6eb3f31ca95ece017f2bfa99122997f989286988058ed9688e49d00631c63d8e4e52da1050e23f02b28d0e739aee7302b24c8808370e
diff --git a/dev-python/chardet/chardet-3.0.4-r1.ebuild b/dev-python/chardet/chardet-3.0.4-r1.ebuild
deleted file mode 100644
index 747b00b7e042..000000000000
--- a/dev-python/chardet/chardet-3.0.4-r1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Universal encoding detector"
-HOMEPAGE="https://github.com/chardet/chardet https://pypi.org/project/chardet/"
-SRC_URI="https://github.com/chardet/chardet/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-# SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-# PyPI tarball is missing test.py: https://github.com/chardet/chardet/pull/118
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
-
-DEPEND="
- test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-pytest-4.patch
-)
-
-distutils_enable_tests pytest
diff --git a/dev-python/chardet/files/chardet-3.0.4-pytest-4.patch b/dev-python/chardet/files/chardet-3.0.4-pytest-4.patch
deleted file mode 100644
index eef88e9e9960..000000000000
--- a/dev-python/chardet/files/chardet-3.0.4-pytest-4.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 0561ddcedcd12ea1f98b7ddedb93686ed8a5ffa4 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
-Date: Tue, 12 Mar 2019 18:44:36 +0100
-Subject: [PATCH] Support pytest 4, don't apply marks directly to parameters
-
-Fixes https://github.com/chardet/chardet/issues/173
----
- test.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test.py b/test.py
-index 9833307..ad2b753 100644
---- a/test.py
-+++ b/test.py
-@@ -59,7 +59,7 @@ def gen_test_params():
- full_path = join(path, file_name)
- test_case = full_path, encoding
- if full_path in EXPECTED_FAILURES:
-- test_case = pytest.mark.xfail(test_case)
-+ test_case = pytest.param(*test_case, marks=pytest.mark.xfail)
- yield test_case
-
-