summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-09-06 23:06:55 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-09-07 21:45:19 -0400
commit6005265af19abc7d25bc9d884ed7516c73ee2a6e (patch)
tree40d7715947f0e736a7ed6deea94ab7a45fd0456e /dev-python
parentnet-p2p/syncthing: remove old (diff)
downloadgentoo-6005265af19abc7d25bc9d884ed7516c73ee2a6e.tar.gz
gentoo-6005265af19abc7d25bc9d884ed7516c73ee2a6e.tar.bz2
gentoo-6005265af19abc7d25bc9d884ed7516c73ee2a6e.zip
dev-python/superlance: bump to 0.13
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/superlance/Manifest1
-rw-r--r--dev-python/superlance/superlance-0.13.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/superlance/Manifest b/dev-python/superlance/Manifest
index 056f892078b4..3c6a55b94431 100644
--- a/dev-python/superlance/Manifest
+++ b/dev-python/superlance/Manifest
@@ -1 +1,2 @@
DIST superlance-0.11.tar.gz 33882 SHA256 ab3aa27f2985c840f59f19b90e75b62e43d8d70e41b0cdc6523a884fb32f9d6e SHA512 bdf6da9e26f4db6f32f79cc27987fd75d2902ca6c098cf9c07785791fe50d3546348689391636eac25d963cd09edb2e57669e5526e68bddfd78c88eb9918fd91 WHIRLPOOL 9c85c8a68d60b195c5cb8d67a0f4e47cf5701c3b2b6711ad28ae1b11cf81723a9c0265e29f0cfed7d415d375a42abe0147101444b9fb969db598a3b786bb8140
+DIST superlance-0.13.tar.gz 35009 SHA256 51fb4c990ed6dda553fbc541c5d638b614dfd8bd2832a3d958300c75dc2bf83a SHA512 283a49f345901c9212b4fa44b6cf47590c70ee9861bcedaf5c85ef74b445998e890daf9aa2d45ca32e66e8b41d9ca54eb12d860403c536265415e473dc8a2ffc WHIRLPOOL c8203367bec0f8c14c1b28607a5cd77f65a0d34a07f09bd32127fcc0dbbde280a9ff0bdfffe113c1122deb9a16225e9d9df60ad8aa616942fe042ca2e5e5749e
diff --git a/dev-python/superlance/superlance-0.13.ebuild b/dev-python/superlance/superlance-0.13.ebuild
new file mode 100644
index 000000000000..a4830dd2b47c
--- /dev/null
+++ b/dev-python/superlance/superlance-0.13.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A set of plugins to monitor and control supervisor"
+HOMEPAGE="https://github.com/Supervisor/superlance"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="app-admin/supervisor[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ # https://github.com/Supervisor/superlance/issues/91
+ # https://github.com/Supervisor/superlance/issues/92
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}