summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-29 07:18:51 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-29 10:02:56 +0200
commit6ddf61872aac25c30415d088c2ff7f6f5396d5a1 (patch)
tree5cbe205cbd2335517d4e8b0816975190811aee5d /dev-python
parentdev-python/pip: Bump to 20.2 (diff)
downloadgentoo-6ddf61872aac25c30415d088c2ff7f6f5396d5a1.tar.gz
gentoo-6ddf61872aac25c30415d088c2ff7f6f5396d5a1.tar.bz2
gentoo-6ddf61872aac25c30415d088c2ff7f6f5396d5a1.zip
dev-python/sphinxcontrib-spelling: Bump to 5.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.2.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index 541660b313c8..f9c12ac0e1bd 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1,2 +1,3 @@
DIST sphinxcontrib-spelling-5.1.0.tar.gz 22942 BLAKE2B 00861b429b66667ed45791f9dd8394b23cf2982875a9e3470c1e2dee22ff0500515d409821a73e46b49bcf397e9ef40f377f933e460b8673579b1f234bf157e4 SHA512 22c5c4eac56c0138e33aae38c2ed1d254211c502087e4c0ebebf2b3b7df69d2567cacde394abb2d8385eab48ea6e3ac9282c980bc8b52408f46bc06ab9634fa4
DIST sphinxcontrib-spelling-5.1.2.tar.gz 22962 BLAKE2B c7b15289b4b6dce5e6c5fb529c4be2cd7c1f41d8bfc6ac86daf1a982f711bd2c426d9b3a615471538fe221197b64ccd907efd4620ea2440f6ec07b2a078d6bee SHA512 4a0398b7c79a035e12d9ae96100fcaa4df42aeae07a01a73f7d875ba04fbbeb3d7441c9debe77491876d78b0a3753677cff4cb3a575e3490364fe5780f5a70b2
+DIST sphinxcontrib-spelling-5.2.0.tar.gz 43860 BLAKE2B 535ec4d8d6f924c9f01b10599725295b1f96f47e999393fbc603725b0eb4ffccf7f12be636cc2d9d045251cae075a3e851f3de4cee5d64ca24ca2056a5406274 SHA512 a17932c5b656cfb76a1389d7c56d71b41d0dda37fae0449db2e03ae1694a6741d20ce2b057ff8bc5fc4fc26c91e07f5a1106470deeea2633ca7a60bc7537c2aa
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.2.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.2.0.ebuild
new file mode 100644
index 000000000000..9cd2451e0691
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://github.com/sphinx-contrib/spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-1.7.0[${PYTHON_USEDEP}]
+ ' python3_{6,7})
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-dicts/myspell-en
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source --no-autodoc
+distutils_enable_tests pytest
+
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}