summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-12-07 09:47:16 -0600
committerMatthias Maier <tamiko@gentoo.org>2017-12-07 10:02:11 -0600
commit7301d2e6d89ee10e7be670d81336bdceb5973ac6 (patch)
tree3157ef2158799895dc1b813b2775f04301fcd02a /dev-python
parentapp-emulation/libvirt: version bump to 3.10.0 (diff)
downloadgentoo-7301d2e6d89ee10e7be670d81336bdceb5973ac6.tar.gz
gentoo-7301d2e6d89ee10e7be670d81336bdceb5973ac6.tar.bz2
gentoo-7301d2e6d89ee10e7be670d81336bdceb5973ac6.zip
dev-python/libvirt-python: version bump to 3.10.0
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/libvirt-python/Manifest3
-rw-r--r--dev-python/libvirt-python/libvirt-python-3.10.0.ebuild46
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 1b180f662979..54a96e088062 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1,2 +1,3 @@
+DIST libvirt-python-3.10.0.tar.gz 184402 BLAKE2B f3ae1626dc6fe2afc2eb7754f6872a6696389bc13a3e8f557c6487e83e3ef66104251910fb4841a2f8b1667cec0418b87ad5a7e9ababf76a39a0f4adaec23bc4 SHA512 bbab01d43b1d9e682c5590c1ea1454c8891f2c545b49f48220f4e79ec4b5b01ab1736242a96653256e26fdf644389c4021747117978a9ec4e1084001de9f23f9
DIST libvirt-python-3.8.0.tar.gz 184346 SHA256 5fcba9ca645b01a8d970da84f7f95d54b0e8e915739d06b5e6d86ae626ea570b SHA512 40fcc67bf793b298016171751f207d65d98c8fe3e04d72bf4a815aab3c2f91a624fde1e0f1a420a67f4cf330874d7dd91ae46c3118e75067030ee551957a8178 WHIRLPOOL 15d815b5f6086e0ffc0f2688aef517c8a62fb89dfb123b6ce3b63a6190b885ef918e16e42fb9dd4d4f2178cf16777be6fc8aeba8d0115d8b3cac3f3a32f8cab4
-DIST libvirt-python-3.9.0.tar.gz 184365 SHA256 d721c812e002eb784a4b66fbe698dc70e8f42c9b7cc3a96f5b01e83ee7951850 SHA512 fe30d308fb81e08600adbac4ec80e28c24d012ee578686506e5615f22b716067795a76b3c37c4a951ca53d9d6642d2b43636924b2d256480dc24eb660a0225a4 WHIRLPOOL 8ecaad10aa557ffecaf22b6ec1eae2698cec7c126765c20ce3033ba5cb8569ab2b737a48e5532f254d65e5fce1f055f02ff5662ae28718118edbddedda784210
+DIST libvirt-python-3.9.0.tar.gz 184365 BLAKE2B ad9331d8ed8697bdee5e36f1ec292020d5610d6ecfbcea4403bf8be5a19dd9d2fd8f6c16803ebd737ab8687634b3cf7dc70518058483da0caa9c7beff2f619c4 SHA512 fe30d308fb81e08600adbac4ec80e28c24d012ee578686506e5615f22b716067795a76b3c37c4a951ca53d9d6642d2b43636924b2d256480dc24eb660a0225a4
diff --git a/dev-python/libvirt-python/libvirt-python-3.10.0.ebuild b/dev-python/libvirt-python/libvirt-python-3.10.0.ebuild
new file mode 100644
index 000000000000..c16440985c37
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-3.10.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}