summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-27 13:32:59 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-27 14:17:12 +0100
commit831eca214ed84f7c890f8e8477c5d646519346c1 (patch)
tree978da913eb335da9c6b1ee7a4de537c841b2a594 /dev-python
parentdev-python/pytest: Remove redudant version (diff)
downloadgentoo-831eca214ed84f7c890f8e8477c5d646519346c1.tar.gz
gentoo-831eca214ed84f7c890f8e8477c5d646519346c1.tar.bz2
gentoo-831eca214ed84f7c890f8e8477c5d646519346c1.zip
dev-python/pytest: Bump to 5.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-5.3.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 0a0234192f65..d308404a1a38 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -2,3 +2,4 @@ DIST pytest-3.10.1.tar.gz 892420 BLAKE2B 38849ae69bf4380bc1a99aa105cac04be078da4
DIST pytest-4.5.0.tar.gz 943607 BLAKE2B 49a0e91fda7f4231fdd39f90eb2daa344d3034c10faff221330ea0ae7482a2a7d0fb9443a0a264db00f1d92568d5a6005cb73e07d8643b46906f7ecff831adcb SHA512 cbffc6216f83491b1de241058315c116697bfaa5206b5f558192a7f861d43dd036d30d0d689bedae7bdee4f0258dd19ef5827c356e11863dd596a5fabe8249fc
DIST pytest-4.6.6.tar.gz 954899 BLAKE2B d3d76ec1fff18d343cc799f1acd0889489f303cdba72747881dfab8656599bc1865f01b5ad2754f0d05bda04aca4d7edf8c2071f2257fdf41506308d1bc0f623 SHA512 c5b6c21c352787eadce06be7529ecb6f6fd5f5eb193ec29e5a4cfff3d7e305f50c6f07aeac15bddce007d88077a35a8f59633111815321792ed3d9fa1011b684
DIST pytest-5.3.0.tar.gz 992537 BLAKE2B 4386d1623bdc168313a75847dfa33413ab1b6a4de9380c67ae866a579dbeb62d8cd18da899bf0476827d6e4a76ddfc5fee7a2fdc652eff0c8848c0bd96045c47 SHA512 285d0b4f6b87b141d6d5dac368dc46eb80dd025d7ed4ad0db937fcc76efc1f8cf251ca9b0786ab1bdadd89c07ad8ddd74f2b3496f97326e9d7fccfd004b98aff
+DIST pytest-5.3.1.tar.gz 994584 BLAKE2B 3831902684d935389b4684af1279a5834edbbe846f8fdb1ce1e64990ab65d6fe8ed3cf5daa446cd20daafe9eedc6f57e01b16d74a55631ab746750a73056640d SHA512 e949a516c064a7050a0ad15356cc0bf25e4840e830f03e1925530c8a2dd9903d7632e55535894474422ba86fd9ed7a397c483d98dad297990b7b49456147189e
diff --git a/dev-python/pytest/pytest-5.3.1.ebuild b/dev-python/pytest/pytest-5.3.1.ebuild
new file mode 100644
index 000000000000..9795396ca686
--- /dev/null
+++ b/dev-python/pytest/pytest-5.3.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.5.0"
+
+# pathlib2 has been added to stdlib before py3.6, but pytest needs __fspath__
+# support, which only came in py3.6.
+RDEPEND="
+ >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python3_5 )
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ <dev-python/pluggy-1
+ >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]"
+
+# flake cause a number of tests to fail
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-40[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-4.5.0-strip-setuptools_scm.patch
+)
+
+python_prepare_all() {
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+
+ # Something in the ebuild environment causes this to hang/error.
+ # https://bugs.gentoo.org/598442
+ rm testing/test_pdb.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" "${BUILD_DIR}"/lib/pytest.py -vv --lsof -rfsxX \
+ || die "tests failed with ${EPYTHON}"
+}