summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-11-07 10:59:56 -0800
committerZac Medico <zmedico@gentoo.org>2017-11-07 11:03:03 -0800
commit85d4a5455574734bbb97c5218541a9617ebd2f9b (patch)
tree349836d39cf2ed82d942b852a6bf8245bca78d10 /dev-python
parentdev-python/cli_helpers: version bump to 1.0.0 (bug 636824) (diff)
downloadgentoo-85d4a5455574734bbb97c5218541a9617ebd2f9b.tar.gz
gentoo-85d4a5455574734bbb97c5218541a9617ebd2f9b.tar.bz2
gentoo-85d4a5455574734bbb97c5218541a9617ebd2f9b.zip
dev-python/pyghmi: blocker older cli_helpers (bug 636824)
This fixes the following build failure: >>> Compiling source in /var/tmp/portage/dev-python/pyghmi-1.0.22/work/pyghmi-1.0.22 ... * python2_7: running distutils-r1_run_phase distutils-r1_python_compile /usr/bin/python2.7 setup.py build ERROR:root:Error parsing Traceback (most recent call last): File "/usr/lib64/python2.7/site-packages/pbr/core.py", line 111, in pbr attrs = util.cfg_to_args(path, dist.script_args) File "/usr/lib64/python2.7/site-packages/pbr/util.py", line 267, in cfg_to_args wrap_commands(kwargs) File "/usr/lib64/python2.7/site-packages/pbr/util.py", line 569, in wrap_commands cmdclass = ep.resolve() File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 2415, in resolve module = __import__(self.module_name, fromlist=['__name__'], level=0) ImportError: No module named tasks error in setup command: Error parsing /var/tmp/portage/dev-python/pyghmi-1.0.22/work/pyghmi-1.0.22/setup.cfg: ImportError: No module named tasks See: https://github.com/dbcli/cli_helpers/issues/25 Closes: https://bugs.gentoo.org/636824 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyghmi/pyghmi-1.0.22.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/pyghmi/pyghmi-1.0.22.ebuild b/dev-python/pyghmi/pyghmi-1.0.22.ebuild
index 7af3e3962a6..3be2b5d11b8 100644
--- a/dev-python/pyghmi/pyghmi-1.0.22.ebuild
+++ b/dev-python/pyghmi/pyghmi-1.0.22.ebuild
@@ -17,7 +17,9 @@ IUSE="test"
RDEPEND="dev-python/pbr[${PYTHON_USEDEP}]
>=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]"
+#636824 older versions of cli_helpers break the build
DEPEND="${RDEPEND}
+ !<dev-python/cli_helpers-1.0.0
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
>=dev-python/coverage-3.6[${PYTHON_USEDEP}]