summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-14 12:38:20 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-14 12:38:42 +0200
commit8db3762f29d24210736be7d1877f516431f9b44a (patch)
tree8466313c28b4bd20044206b6224a9cb9e0565d12 /dev-python
parentsci-mathematics/pymc3: Remove unused dep on (re)commonmark (diff)
downloadgentoo-8db3762f29d24210736be7d1877f516431f9b44a.tar.gz
gentoo-8db3762f29d24210736be7d1877f516431f9b44a.tar.bz2
gentoo-8db3762f29d24210736be7d1877f516431f9b44a.zip
dev-python/commonmark: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/commonmark/Manifest2
-rw-r--r--dev-python/commonmark/commonmark-0.5.4.ebuild36
-rw-r--r--dev-python/commonmark/commonmark-0.8.1.ebuild44
3 files changed, 0 insertions, 82 deletions
diff --git a/dev-python/commonmark/Manifest b/dev-python/commonmark/Manifest
index 039374f4fc12..a5c1b46757db 100644
--- a/dev-python/commonmark/Manifest
+++ b/dev-python/commonmark/Manifest
@@ -1,3 +1 @@
-DIST CommonMark-0.5.4.tar.gz 120316 BLAKE2B 47904d101d9d0e3759f82c28a4b80edfc0ed12cf0888e4915339118e496322cf0791d8a46d2edddca0d1794e82a9647cc22cbcfcc2d385a740c7c31cb8251659 SHA512 1983714a50a627f30f86af0d02dad9e52cb7b0ffce29691d0e740f587e599ead6de2412d72b895b7df772e1c81e171e56dfecaf593e611af65bd5798632a98ad
-DIST commonmark-0.8.1.tar.gz 90795 BLAKE2B 718c2b1af035672d74e2c6b6f89ea0cd23f45d7b0e47b6dadeef742d772f5458e08ec5f69fd4f34df9ab2c491d9d7add4c4acc7018c4048649aa0d8244d7db91 SHA512 dbab51d45c1973a8d0906148d785fb8ddc2b52177dfe0e69fe79bef2a5eb05a5a7ab8693852f4aaa8545af19d741569d04a24f06ea65171e6e80d9f66af47fdf
DIST commonmark-0.9.1.tar.gz 95764 BLAKE2B 1f61de784c5cf03aa5255f5fae18c48df30aab8ef135ccf85a0b7a14cfc64275476458fc0853ecfc9beee96daca31d5cccb30d218f7d5b5343844e57aa7a77ec SHA512 bacf5ef387a0c330a2128f42c42c29c1a48ae623683e6e56ad28a1621aabd72e29cd3e2d661e8207b8cc0c347d267f262a55f2145fc58f8c8aeff91e7a283324
diff --git a/dev-python/commonmark/commonmark-0.5.4.ebuild b/dev-python/commonmark/commonmark-0.5.4.ebuild
deleted file mode 100644
index ab0f369be3e8..000000000000
--- a/dev-python/commonmark/commonmark-0.5.4.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN=CommonMark
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Python parser for the CommonMark Markdown spec"
-HOMEPAGE="https://github.com/rtfd/CommonMark-py"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- dev-python/future[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-S=${WORKDIR}/${MY_P}
-
-# unrestrict for versions >= 0.7.2
-RESTRICT=test
-
-python_test() {
- LC_ALL='en_US.utf8' LC_CTYPE='en_US.utf8' LANG=en_US.utf8 PYTHONIOENCODING=UTF-8 \
- esetup.py test
-}
diff --git a/dev-python/commonmark/commonmark-0.8.1.ebuild b/dev-python/commonmark/commonmark-0.8.1.ebuild
deleted file mode 100644
index e2b30049848d..000000000000
--- a/dev-python/commonmark/commonmark-0.8.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python parser for the CommonMark Markdown spec"
-HOMEPAGE="https://github.com/rtfd/CommonMark-py"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/future[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/hypothesis-3.7.1[${PYTHON_USEDEP}]
- )
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-python_test() {
- PYTHONIOENCODING='utf8' \
- esetup.py test
-}
-
-src_prepare() {
- default
- # Fix file collision with app-text/cmark, see bug #627034
- sed -i -e "s:'cmark\( = commonmark.cmark\:main'\):'cmark.py\1:" \
- setup.py || die
-}
-
-pkg_postinst() {
- ewarn "/usr/bin/cmark has been renamed to /usr/bin/cmark.py due file"
- ewarn "collision with app-text/cmark (see bug #627034)"
-}