summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-19 11:43:40 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-19 14:25:26 +0100
commit99330f036fd76e5889803340b3731a9ddaf19feb (patch)
tree5c6580fdcbb82ccbb660236a83f4d787ba046173 /dev-python
parentsys-kernel/gentoo-kernel-bin: Bump to 5.5.10 (diff)
downloadgentoo-99330f036fd76e5889803340b3731a9ddaf19feb.tar.gz
gentoo-99330f036fd76e5889803340b3731a9ddaf19feb.tar.bz2
gentoo-99330f036fd76e5889803340b3731a9ddaf19feb.zip
dev-python/python-bugzilla: Modernize, py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild b/dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild
index 3ee2bd198d44..a8ba9b873d82 100644
--- a/dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild
+++ b/dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -20,10 +20,5 @@ SLOT="0"
RDEPEND="
|| ( dev-python/python-magic[${PYTHON_USEDEP}] sys-apps/file[python,${PYTHON_USEDEP}] )
dev-python/requests[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-python_test() {
- "${EPYTHON}" ./setup.py test || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests setup.py