summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-04 02:36:31 +0100
committerAaron Bauman <bman@gentoo.org>2019-12-04 11:36:58 -0500
commit9d35b821aa69d77e7bf8177af17b229e5a81947d (patch)
tree11da6075662f6c245d76797efe7960da31fb3731 /dev-python
parentdev-python/paramiko: python3_8, use distutils_enable_sphinx (diff)
downloadgentoo-9d35b821aa69d77e7bf8177af17b229e5a81947d.tar.gz
gentoo-9d35b821aa69d77e7bf8177af17b229e5a81947d.tar.bz2
gentoo-9d35b821aa69d77e7bf8177af17b229e5a81947d.zip
dev-python/pytest-runner: 5.2 version bump, python3_8
Use distutils_enable_sphinx Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13814 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-runner/Manifest1
-rw-r--r--dev-python/pytest-runner/pytest-runner-5.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-runner/Manifest b/dev-python/pytest-runner/Manifest
index c9065c2f3808..d024ac74ad5e 100644
--- a/dev-python/pytest-runner/Manifest
+++ b/dev-python/pytest-runner/Manifest
@@ -2,3 +2,4 @@ DIST pytest-runner-2.11.1.tar.gz 9661 BLAKE2B 300b63de61ef36c299a95c60af469b071c
DIST pytest-runner-2.6.2.tar.gz 6379 BLAKE2B 4f676a4cd59309cdd0e6462c83718482622817781d302ed95a2b7cb9d92a0b0f38b411c1172ecce9003f5781cdb168338bce6f446b1c91069a2024fb75574bfc SHA512 6a993e8729d5e203986f2526d46e96b7ac19e65fc26493a55a98e858304ecde0c47576476864a0ee1817ea1a7b02cfda952fc03f79b84fff249021f140f3d00d
DIST pytest-runner-4.0.tar.gz 11401 BLAKE2B 3be4527e68b8c1ae7e1bb5bad111367e459a07cf20de1f3b2d8ab993a7e016f9656618075bf515f576fef457aa86f99990f7dcc4c20a04166703bf9272c395c1 SHA512 a7f3defcc698f43b3b6ceec3f59dbd0e00c651167ddc76a9d1a093d722a013c9ffd2bad3438e49170688d503166cb6d8bf55bbaf7bc6f9e6d80eff049c202b08
DIST pytest-runner-4.2.tar.gz 11947 BLAKE2B 97495bead800a81d879659f1ee522822f76fe8ac80579537d43e21e663323d7c10be8d2da7d05ffdb0931145149d8c10ef7c72b3ab4da2ce856d44d3f00a724e SHA512 278da7add27f77134e63470747ffd9fe663d93ab8e7cebfbae98902bb1d5ffba45277574107f958255251cb9e499b85a0db3e8173f9f10fb31d1561ca709a379
+DIST pytest-runner-5.2.tar.gz 15534 BLAKE2B 0bcbd5991808aaa4b85b9071ce142e03287683e919687fa76f5b7929ad07dca6ae6edaf7ad30a1bc1ba0163f43505ec18ab2cd5e0462399b8252c8ca761d7b29 SHA512 5fc62a4e681cfa0ef25dc815ccbbfe1a7ca0e9e7783c2ba2db0da7d2539f11c08d6c3fad2ab3dfe7f0d50fe7bfb41127b11ec9af67ef8e32361655bc910c8245
diff --git a/dev-python/pytest-runner/pytest-runner-5.2.ebuild b/dev-python/pytest-runner/pytest-runner-5.2.ebuild
new file mode 100644
index 000000000000..353d2171777f
--- /dev/null
+++ b/dev-python/pytest-runner/pytest-runner-5.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds support for tests during installation of setup.py files"
+HOMEPAGE="https://pypi.org/project/pytest-runner/ https://github.com/pytest-dev/pytest-runner"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="
+ >=dev-python/setuptools-40.6.3[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/jaraco-packaging[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+ test? ( ${RDEPEND} )
+"
+
+distutils_enable_sphinx docs
+
+# Tests require network access to download packages
+RESTRICT="test"
+
+python_test() {
+ esetup.py pytest
+}