summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-29 09:39:30 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-29 12:45:50 +0100
commita5a1f5de3235884f8939199331e2f9bd62bcf590 (patch)
treee51d79aebc176a4b600988c6ba16f85a4cc3d5f9 /dev-python
parentdev-ruby/rack-test: fix test deps (diff)
downloadgentoo-a5a1f5de3235884f8939199331e2f9bd62bcf590.tar.gz
gentoo-a5a1f5de3235884f8939199331e2f9bd62bcf590.tar.bz2
gentoo-a5a1f5de3235884f8939199331e2f9bd62bcf590.zip
dev-python/botocore: Bump to 1.19.44
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.44.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index c5a7e003a2d0..c8c5545d6ce6 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.19.40.tar.gz 7371480 BLAKE2B afd861d013b78487ff2a6d47a531536f392
DIST botocore-1.19.41.tar.gz 7368333 BLAKE2B d70ebbcfe4e4d44893f69214bda2341f047ef036434d37bdf3ec632745ac20c30f7321a03ecbfb8e8cdf42052e27a40e8f6c02ab57e471ca7d78ef28640d1029 SHA512 63edfaa02f8b79caca70611cb3ed16732813c072473ab39a4f7525cab882e2b1fac1b4a3664524db76d6288cdb4b6f650492432acaa38e2dd63b46baa7d6d0a2
DIST botocore-1.19.42.tar.gz 7371856 BLAKE2B 09d0ebbb495bc590c4f944a7ca6d91d5069d4d8eac061ab6709e5f908ff6691c8148168ddbf93874acb014d96f6ed37ac260e4263bf1c7ad55b5de545ce5f752 SHA512 779eab3a31aa2572af868b0355ff25b0d0f1cc9748494fc26bf6888e90383eea2da0ca141cde60303eaf39b4ec80971dedea415a3bde5215c982618f0c475b83
DIST botocore-1.19.43.tar.gz 7374325 BLAKE2B 7def5221bee4774a6b8a33e6499e499588ff18f8b144e669bdf9b01ae4a3e370e3aed5a3a960360123e57299da9b0293aa8da9108fe114f8ae34521b2920f479 SHA512 a1b97cbb779d8c8fe3495dd18d3d635e38c5c49e5b5fb31b7764029cf3063a7fda44711defc45783b3afb844bead46e686705af57472a7ff27af8b7e21645ad5
+DIST botocore-1.19.44.tar.gz 7374043 BLAKE2B 57548d1ccf963c1c2c33f9fdb365e04d60afc63f6112fdf689c7caab89dc242f94ae1680e69a24cb709c8b7e1190acf12e487a9289a482d7f96c02820b4b13ac SHA512 d865780c8f904b3f67c61a1e073ff4e2c6f77478168dcd98b034634a1796c07a94d8125033fc7475c7554898a73d3def8225a88eb5ec01d9064ea8737cc9eb23
diff --git a/dev-python/botocore/botocore-1.19.44.ebuild b/dev-python/botocore/botocore-1.19.44.ebuild
new file mode 100644
index 000000000000..ca40b64d111f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.44.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}