summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-23 04:05:53 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-23 04:11:35 +0200
commitaaf2cc7b8fc70366487e1a13c9bbd71df8839c2d (patch)
tree9d1f625c665a073e7ff3b7b2ffd57abb4483204d /dev-python
parentdev-python/sphinxcontrib-plantuml: Bump to 0.30 (diff)
downloadgentoo-aaf2cc7b8fc70366487e1a13c9bbd71df8839c2d.tar.gz
gentoo-aaf2cc7b8fc70366487e1a13c9bbd71df8839c2d.tar.bz2
gentoo-aaf2cc7b8fc70366487e1a13c9bbd71df8839c2d.zip
dev-python/autopep8: Bump to 2.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-2.1.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 7fe7d3ab4421..9a94e5606a00 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1 +1,2 @@
DIST autopep8-2.1.0.tar.gz 88891 BLAKE2B 60bd5e9a177d8bdb741b37884bb3ef170fb59664b740beb1b1f38df021dfb7916f2cecdb2e20b6363c2abcc110f9f36902dbccd7f06ddf56f090ccb36149fb19 SHA512 f694a506646b4bc4932fb07cf1c989897e7db3fc9b65dc90886fa657b163dfcbad4c16bb911a2e399a4623b167b313d32213762d3e21e20bff27b6fe2a5abc59
+DIST autopep8-2.1.1.tar.gz 91009 BLAKE2B fa324c2c2e827a4bd5c3f60e0fbb83419055a5b0ced7c737b590cdfba9c43f6517ac659bc77212d9694530d42d6ea4c9af642acf5074d514b32a11c62dcc3688 SHA512 cfa9927e44d40d778405fa1a49385c40b79dd425d945ec5053510c594e783f98aaaf083ad53a07b04cf929eac9b274c5a37c8a1256ebb83d897364d40fc9eba0
diff --git a/dev-python/autopep8/autopep8-2.1.1.ebuild b/dev-python/autopep8/autopep8-2.1.1.ebuild
new file mode 100644
index 000000000000..6a718a775d3f
--- /dev/null
+++ b/dev-python/autopep8/autopep8-2.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="
+ https://github.com/hhatto/autopep8/
+ https://pypi.org/project/autopep8/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.11.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest