summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-05 08:53:28 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-05 10:28:25 +0200
commitba312d9a19ae7cef69954da5609528b11df202ad (patch)
treeed3ed67f2bb023eb2e6c3fa4337c7429dc432389 /dev-python
parentdev-python/identify: Bump to 2.2.9 (diff)
downloadgentoo-ba312d9a19ae7cef69954da5609528b11df202ad.tar.gz
gentoo-ba312d9a19ae7cef69954da5609528b11df202ad.tar.bz2
gentoo-ba312d9a19ae7cef69954da5609528b11df202ad.zip
dev-python/requests-cache: Bump to 0.6.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests-cache/Manifest1
-rw-r--r--dev-python/requests-cache/requests-cache-0.6.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index 31aff9002aee..01307336593a 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -3,3 +3,4 @@ DIST requests-cache-0.6.0.tar.gz 52342 BLAKE2B 12af89721fcf1ae2e4ab14d7ac377f119
DIST requests-cache-0.6.1.gh.tar.gz 47919 BLAKE2B 022fd94a332feae043cf646cefc368fdb6ca1833dcd58621a07425bfb0d7bcb5ff9913c8b53f2bc0769fd23e8f364c437ee10f16fd37d1d340e8c46bcba9d53e SHA512 f8bea03b05b2f1e55fe6c975b5f5caacff55250d81f41cf953052c77101fc726ff39f9d95e1fd2829ddb59215226026bdddfd93918feb478395375ac0e0a4439
DIST requests-cache-0.6.2.gh.tar.gz 47962 BLAKE2B f0597f3c5f4a678b94f3b15023e3aba5247de3d79043e7e1cbd4ab0f2d4457e2f5feab130665129ae87baba56576312b1420ae16c2a34b44dc780bf05351615c SHA512 c97119127b1e80e6eec02938b2e0e8de785875f46d348215e05ee2d668feb77ed40f0dad4ed4a3ae53fb8e6708c8d7b13788e54694a38cef3ce22e83f13f97e2
DIST requests-cache-0.6.3.gh.tar.gz 50303 BLAKE2B e8507a19f3883c050e1d819bf9ce8ebf720a5c6517e4004ecf745f5a197a8feac9cbca18ffa99001be0baffbad41d2ebfba5b63d90b55eda1d754d279242bbc6 SHA512 1fa801f60623dce0a5cd834272a74acf80b6ae52a602ae81fbd7e3653467800d9a58fb8220e30d53ef1b896aa01f2017f93dcbc2dacfd685ee9ae286f47077f5
+DIST requests-cache-0.6.4.gh.tar.gz 50322 BLAKE2B c9a6cae957604bdfa6057621e028fad83476e5d918bbf9c58e73f09f8615398946f3cf6e3737c9ff916cba68d82ed66a674557fb733c74b874b0f68e2430d9a0 SHA512 31e2217e54892d8ec5fc9fcf60f650960621b1f97029c90deca925b9a1be9eb5a3ddb6ae68e581c805f20136f93eefa70d51e7e9f086ecbae76f8e550bbe3f1a
diff --git a/dev-python/requests-cache/requests-cache-0.6.4.ebuild b/dev-python/requests-cache/requests-cache-0.6.4.ebuild
new file mode 100644
index 000000000000..bf347f9dcc78
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-0.6.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="
+ https://pypi.org/project/requests-cache/
+ https://github.com/reclosedev/requests-cache/"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="
+ https://github.com/reclosedev/requests-cache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local skipped_tests=(
+ # These require extra servers running
+ tests/integration/test_dynamodb.py
+ tests/integration/test_gridfs.py
+ tests/integration/test_mongodb.py
+ tests/integration/test_redis.py
+ )
+
+ local -x USE_PYTEST_HTTPBIN=true
+ epytest ${skipped_tests[@]/#/--deselect }
+}