summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-11 09:10:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-11 09:50:48 +0200
commitc8afe9c601d8e634e0479ee8015ef56d2fcf7b75 (patch)
tree6f44f7de1cd2b50d8e151727f440c5e96acbed3c /dev-python
parentdev-python/pytest-mock: Mark ALLARCHES (diff)
downloadgentoo-c8afe9c601d8e634e0479ee8015ef56d2fcf7b75.tar.gz
gentoo-c8afe9c601d8e634e0479ee8015ef56d2fcf7b75.tar.bz2
gentoo-c8afe9c601d8e634e0479ee8015ef56d2fcf7b75.zip
dev-python/setuptools: Bump to 49.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-49.1.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index eccc5922da1f..74a623d3abc2 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -4,3 +4,4 @@ DIST setuptools-46.4.0.zip 865912 BLAKE2B 452d36132f5648c79c7e1616a93ff6a39ab2f6
DIST setuptools-47.1.1.zip 870277 BLAKE2B 0ba55f2b51011d4f98a554a959227dba83a79e7369a3cd54450a1d18cb378bf7cfaffc1aa25b0ee11760e917d6f74891f0a63e43478893ca4327e0f5135267dc SHA512 053ffd4c26bf0cf1894754b1ed922be03c6fa2cb54a41e3d28a7d8f7a2fdf2ccebbca4e0bafa16eed476923ef70cf4294ed36df6e77603b2fae0a09b684132c4
DIST setuptools-47.3.1.zip 869963 BLAKE2B cecc4d43ce09708c2454c20064baf8b5597aff29bf069a859ec7d6a91588456455df611f962cb90650b23ba269bbedcb81dff568b4498431cfa20f46ece828dd SHA512 05d8ac5e1612f0c22d9f51b5dbb22cdd1edfd9c15e97c5f31f6dee8d660e6ca19720cee5169158d0179baa87518766fda1cd2e4d5c69f683e973a9ff08155d48
DIST setuptools-49.1.0.zip 2170689 BLAKE2B fa5f9a8955ac4206396c653a3c6b5926aeb7f6f4052de7b67698ad39edd3d49c7bad13bc65720b5a40a906d06eaf3e6918cfbc20a2a59e100f75400c2caa17df SHA512 a5734742a6d2409f41c62f29dea35c58f480756ef8a66f70aaa607a6927a64487f92d20def6791860ee508e713b44d800e41e2cf8b5abcffd7e1ed1058374efe
+DIST setuptools-49.1.1.zip 2173825 BLAKE2B 44a23a2bb8613b2dcf2368997c7d89ffbd957d7004c1872bbb64631955e5e8ed2f14a49d16fff4c384c42d56b486eb2ee07f2a3e3e72add97502f39309a17fee SHA512 d33c291edb64d015530e3bd66666a612539896018c5f6b6eff65719339ec75967c4f6200be36a60955f885ebc4cb86f9acd5f52d8fd2e1fb1e4919488a986603
diff --git a/dev-python/setuptools/setuptools-49.1.1.ebuild b/dev-python/setuptools/setuptools-49.1.1.ebuild
new file mode 100644
index 000000000000..3f1c94d2fb6d
--- /dev/null
+++ b/dev-python/setuptools/setuptools-49.1.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-arch/unzip
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ # xpass-es for me on py3
+ #sed -e '/xfail.*710/s:(:(six.PY2, :' \
+ # -i setuptools/tests/test_archive_util.py || die
+
+ # avoid pointless dep on flake8
+ sed -i -e 's:--flake8::' -e 's:--cov::' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" pytest -vv ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}