summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-02-28 20:11:22 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-02-28 20:11:22 +0700
commitd121fd441d911050e294801cbf0b3b0163ff2baf (patch)
treedbdc3129b9c02383c782b39183abc9257e5a06ef /dev-python
parentdev-python/pyte: python3_6 added (diff)
downloadgentoo-d121fd441d911050e294801cbf0b3b0163ff2baf.tar.gz
gentoo-d121fd441d911050e294801cbf0b3b0163ff2baf.tar.bz2
gentoo-d121fd441d911050e294801cbf0b3b0163ff2baf.zip
dev-python/watchdog: python3_6 added
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/watchdog/watchdog-0.8.3-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/watchdog/watchdog-0.8.3-r2.ebuild b/dev-python/watchdog/watchdog-0.8.3-r2.ebuild
new file mode 100644
index 000000000000..40fd632aaea8
--- /dev/null
+++ b/dev-python/watchdog/watchdog-0.8.3-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: f7a9a577d9772b9743b2ef7fdb310ae950383ed2 $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="mirror://pypi/w/watchdog/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/pathtools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}