summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-10 18:30:05 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-10 19:11:51 +0200
commitd4e8149dcdb8465717974e2f9e9ee008da918c85 (patch)
tree0e903176b5adb01e72f5c434f4e410462e9ea2ac /dev-python
parentdev-python/pytest-xdist: add 2.5.0 (diff)
downloadgentoo-d4e8149dcdb8465717974e2f9e9ee008da918c85.tar.gz
gentoo-d4e8149dcdb8465717974e2f9e9ee008da918c85.tar.bz2
gentoo-d4e8149dcdb8465717974e2f9e9ee008da918c85.zip
dev-python/sphinx_ansible_theme: add 0.9.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx_ansible_theme/Manifest1
-rw-r--r--dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.9.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/sphinx_ansible_theme/Manifest b/dev-python/sphinx_ansible_theme/Manifest
index 47f0de778d10..32fdcfc9f05d 100644
--- a/dev-python/sphinx_ansible_theme/Manifest
+++ b/dev-python/sphinx_ansible_theme/Manifest
@@ -1 +1,2 @@
DIST sphinx-ansible-theme-0.8.0.tar.gz 34401 BLAKE2B 493663331e593da8d56683991762452419fd5fdb48e2c59ee3a38b6242216bccf56e047e59294ae73cccfb48a66606e55fac6c9a19d91e6ea778920f9919dbd1 SHA512 399af992428dd3212681efa66036af9ae7dbd9a9dd507452686cc76aa3e365aabee0ba7b599fbbed85f1f252075d5158ade9a816a9aad17b4e5ed696be1c962e
+DIST sphinx-ansible-theme-0.9.0.tar.gz 34533 BLAKE2B 53e4169f8deb88c9b0398e745cb249a596b3e63086afd3543d2465e1f2048f587f0a5964ac4a4cdc7a81c2cf78239ec59cd808a4dd644b3faec39b7a2b6487cd SHA512 0610a8422950252d88469dde274e3ac3df85034a886e87dbc9a19d621a55a7fc45d8ffdaf047cf78c556d6eacc09832d718fa5ab8f5019621b37579d84ed4951
diff --git a/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.9.0.ebuild b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.9.0.ebuild
new file mode 100644
index 000000000000..ea5f4402b368
--- /dev/null
+++ b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.9.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN//_/-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A reusable Ansible Sphinx theme"
+HOMEPAGE="https://github.com/ansible-community/sphinx_ansible_theme"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ doc? ( dev-python/ansible-pygments[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs 'dev-python/sphinx-notfound-page'