summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-05-15 09:07:26 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-05-15 12:11:34 -0400
commitdc7b2f2348718477b9d6cd65857dab07bc2a9d8b (patch)
tree7a67e3fe7d5d00a4c48f2e5e3ad73001f5675407 /dev-python
parentdev-python/secretstorage: 3.1.1 (diff)
downloadgentoo-dc7b2f2348718477b9d6cd65857dab07bc2a9d8b.tar.gz
gentoo-dc7b2f2348718477b9d6cd65857dab07bc2a9d8b.tar.bz2
gentoo-dc7b2f2348718477b9d6cd65857dab07bc2a9d8b.zip
dev-python/wcwidth: add support for pypy{,3}
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wcwidth/wcwidth-0.1.7-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/wcwidth/wcwidth-0.1.7-r2.ebuild b/dev-python/wcwidth/wcwidth-0.1.7-r2.ebuild
new file mode 100644
index 000000000000..81af73f089b6
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.1.7-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="https://pypi.org/project/wcwidth/ https://github.com/jquast/wcwidth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ pytest -v -rs --strict wcwidth/tests || die
+}