summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-09-30 12:26:43 -0400
committerMike Gilbert <floppym@gentoo.org>2015-09-30 12:28:03 -0400
commite050af8811e367c50e810b35aa7139fcdabdcd9c (patch)
tree2d497fd8e537f0fa6ef53bd5cdcee3a84e665235 /dev-python
parentnet-misc/pycnb: Simplify permissions fix (diff)
downloadgentoo-e050af8811e367c50e810b35aa7139fcdabdcd9c.tar.gz
gentoo-e050af8811e367c50e810b35aa7139fcdabdcd9c.tar.bz2
gentoo-e050af8811e367c50e810b35aa7139fcdabdcd9c.zip
dev-python/google-apputils: Simplify permissions fix
Package-Manager: portage-2.2.22_p3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-apputils/google-apputils-0.4.0-r1.ebuild3
-rw-r--r--dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild3
2 files changed, 2 insertions, 4 deletions
diff --git a/dev-python/google-apputils/google-apputils-0.4.0-r1.ebuild b/dev-python/google-apputils/google-apputils-0.4.0-r1.ebuild
index 4ed6025a2842..7b78e53c8ddb 100644
--- a/dev-python/google-apputils/google-apputils-0.4.0-r1.ebuild
+++ b/dev-python/google-apputils/google-apputils-0.4.0-r1.ebuild
@@ -27,8 +27,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
src_unpack() {
default
- find ${P} -type d -exec chmod 0755 {} + || die
- find ${P} -type f -exec chmod 0644 {} + || die
+ chmod -R a+rX,u+w,g-w,o-w ${P} || die
}
python_prepare_all() {
diff --git a/dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild b/dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild
index 613b4dcc6735..1e3890860051 100644
--- a/dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild
+++ b/dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild
@@ -26,8 +26,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
src_unpack() {
default
- find ${P} -type d -exec chmod 0755 {} + || die
- find ${P} -type f -exec chmod 0644 {} + || die
+ chmod -R a+rX,u+w,g-w,o-w ${P} || die
}
python_test() {