summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2018-02-26 19:49:39 +0300
committerPatrice Clement <monsieurp@gentoo.org>2018-02-26 22:53:30 +0100
commite3eaeecdc730dfec9f3858ad682068a80eb73a07 (patch)
treed82d569fbc86afd1c8566b8a2620380be57ff89c /dev-python
parentmedia-gfx/aaphoto: remove old. (diff)
downloadgentoo-e3eaeecdc730dfec9f3858ad682068a80eb73a07.tar.gz
gentoo-e3eaeecdc730dfec9f3858ad682068a80eb73a07.tar.bz2
gentoo-e3eaeecdc730dfec9f3858ad682068a80eb73a07.zip
dev-python/ansicolor: add live ebuild.
It has tests! Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7285
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ansicolor/ansicolor-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/ansicolor/ansicolor-9999.ebuild b/dev-python/ansicolor/ansicolor-9999.ebuild
new file mode 100644
index 000000000000..bbb99ff83a32
--- /dev/null
+++ b/dev-python/ansicolor/ansicolor-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
+HOMEPAGE="https://github.com/numerodix/ansicolor"
+EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v || die "Test suite failed with ${EPYTHON}"
+}