summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-05-15 16:18:45 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-05-15 16:18:45 -0500
commite6dae46f8a2daf0bf0efb5ae353edd82eeada079 (patch)
tree3083073cceea9a322ce8014b97e8b4c719346796 /dev-python
parentdev-python/expects: remove version 0.8.0_rc3 (diff)
downloadgentoo-e6dae46f8a2daf0bf0efb5ae353edd82eeada079.tar.gz
gentoo-e6dae46f8a2daf0bf0efb5ae353edd82eeada079.tar.bz2
gentoo-e6dae46f8a2daf0bf0efb5ae353edd82eeada079.zip
dev-python/docker-py: remove version 1.8.0_rc5
The removal of python2_7 in docker-py happened during this release, not the proper release. Removing this version fixes #582300. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/docker-py/Manifest1
-rw-r--r--dev-python/docker-py/docker-py-1.8.0_rc5.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/docker-py/Manifest b/dev-python/docker-py/Manifest
index d3438e3b45c..9df1c780b7c 100644
--- a/dev-python/docker-py/Manifest
+++ b/dev-python/docker-py/Manifest
@@ -1,4 +1,3 @@
DIST docker-py-1.2.2.tar.gz 69685 SHA256 85284a5b1a965e01a5d0a91f9f639ad5069143a276c123198fdafc3659280b38 SHA512 bf00b19e0ab56e5c0e8459234d09722ca504ecd933bfba61cb4ab4805410f53f6ad6083f2e964ef5a6eded2ea05aa01a89c27621064386bae145c7258ed996ad WHIRLPOOL bd7ff4579f924e02d18581b1aca00790dcb84afda03e4cde70b349bfdb4ad43aa2e06da2bcbe780f6074d98f9af9b14fb9d2ab4da9265e56b73288902c9ede7a
DIST docker-py-1.8.0.tar.gz 102575 SHA256 6a2feb4dad94ff01401af1bd1455ca20505af4bb5439f1c80114020461c4cf58 SHA512 60ac793d3061aec4fe46c694a00207560138895c7c6299a6734f2413601648da5130db00dbf33f41c3a91a717d825b9d1ce76413df2ae433b30a61eead373b39 WHIRLPOOL e5e204e7754fe5b038ef218718063892661636bd4ce51a160479725562865076ae2a3c99c38721b7c4f184ba45390f4c5a28582b83311af81da67867cf05a643
DIST docker-py-1.8.0_rc2.tar.gz 100120 SHA256 5176c543343a582f2f7a461560a7c759d002b2dceb7552f542d7d1e0fce3cb05 SHA512 f7924015bc267acb095a9f21d151afd56d787a5d26dcc8c285d81c4e5af8a1027c7f166b8178e3e821a3b2fe541b51121c825ab59591b97bea8eb8a3fe3d7a0f WHIRLPOOL 451fea912c3cdd6bcaf7e29431719c39d7fea9bb03b7b94fbecf493bc28713d97e1438ee6ce8c0fb6977739061c25a87b29e5924e087e8613fe1f115b8000809
-DIST docker-py-1.8.0_rc5.tar.gz 102470 SHA256 0cf741f17233c8aa494c61b053d032d8d296fbc3f11586b1e5efad31fdb46de1 SHA512 1490b913fdac35e226d72f8e926405fde50a249189ccdfe35ae7e5f805fbcb5dee9722666b7d7b3fd23481508f9bfead9a1e231abe49a997c2db370568e8b40f WHIRLPOOL 2a48da6d79a8df59b0cd94a69844bc3d5a048285232faf6f2e118a52bb1bfddaa74b69334fcdb204b7d0be862dfe07ef63c3fb61a4b4fa8e18aba5c8c3be1910
diff --git a/dev-python/docker-py/docker-py-1.8.0_rc5.ebuild b/dev-python/docker-py/docker-py-1.8.0_rc5.ebuild
deleted file mode 100644
index 155e9614162..00000000000
--- a/dev-python/docker-py/docker-py-1.8.0_rc5.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
-
-inherit distutils-r1 vcs-snapshot
-
-MY_PV=${PV//_/-}
-
-DESCRIPTION="Python client for Docker"
-HOMEPAGE="https://github.com/docker/docker-py"
-SRC_URI="https://github.com/docker/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( >=dev-python/mkdocs-0.14.0[${PYTHON_USEDEP}] )
- test? (
- ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- ~dev-python/pytest-2.7.2[${PYTHON_USEDEP}]
- ~dev-python/pytest-cov-2.1.0[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-"
-
-python_compile_all() {
- if use doc; then
- mkdocs build -d 'mkdocs_site' || die "docs failed to build"
- fi
-}
-
-python_test() {
- py.test tests/unit/ | die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( mkdocs_site/. )
-
- distutils-r1_python_install_all
-}