summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-01 09:56:13 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-01 11:31:59 +0100
commite84b3c04701228c1925d687836d549b3444d3aca (patch)
tree6bf9570349195c445ee0dc3c0f025894204bfccf /dev-python
parentdev-python/boto3: Bump to 1.16.26 (diff)
downloadgentoo-e84b3c04701228c1925d687836d549b3444d3aca.tar.gz
gentoo-e84b3c04701228c1925d687836d549b3444d3aca.tar.bz2
gentoo-e84b3c04701228c1925d687836d549b3444d3aca.zip
dev-python/stevedore: Bump to 3.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/stevedore/Manifest1
-rw-r--r--dev-python/stevedore/stevedore-3.3.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/stevedore/Manifest b/dev-python/stevedore/Manifest
index e2ff51783f1b..a2608d158f88 100644
--- a/dev-python/stevedore/Manifest
+++ b/dev-python/stevedore/Manifest
@@ -1 +1,2 @@
DIST stevedore-3.2.2.tar.gz 512174 BLAKE2B 60061f04cee8b4ab1c95ab7c02083abd15a623970168df379c82860bb2ea9b27171f5862851eb194c88001b02878eacab4428a76cbfbe528e7246b3e492abfe1 SHA512 1c3f81157b16af800c1caa971f063c50638a70eced582dbcffafaf7d9bbd4e402f75003fcd73b3cb85940bbe9027bac24e37754ffcacffb06d133e938e07ebcf
+DIST stevedore-3.3.0.tar.gz 513293 BLAKE2B c1eee40a451fd6cad033a618a15cb62e65dc4ead8d2dd9eced4278cd11b1daf0f6fefdba2f2fa8dc1a63b6c525b1a3cbb87c8db12945e7412ed76318ee42592b SHA512 4fdd13c08517aef69700566fc04fb26a29b5a72f73a476d656d134b0d99229a8cf0012d9f1ae4565ffab6fa30e745a013d96da8eff00f8316ae1b5010e4cfbb3
diff --git a/dev-python/stevedore/stevedore-3.3.0.ebuild b/dev-python/stevedore/stevedore-3.3.0.ebuild
new file mode 100644
index 000000000000..794147a53879
--- /dev/null
+++ b/dev-python/stevedore/stevedore-3.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/openstack/stevedore https://pypi.org/project/stevedore/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-1.7.0[${PYTHON_USEDEP}]
+ ' python3_{6,7})
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx 'doc/source' \
+ '>=dev-python/openstackdocstheme-1.18.1' \
+ '>=dev-python/reno-2.5.0' \
+ '>=dev-python/sphinx-2.0.0'
+
+python_prepare_all() {
+ # Delete spurious data in requirements.txt
+ sed -e '/^pbr/d' -i requirements.txt || die
+ distutils-r1_python_prepare_all
+}