summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:51:02 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commitea65382a8442c9c9a909d05f783080a5a88fa1db (patch)
tree690c9d4275a5d4d41346c2d0267afc0752f2f511 /dev-python
parentdev-python/six: Add python3.5 support (diff)
downloadgentoo-ea65382a8442c9c9a909d05f783080a5a88fa1db.tar.gz
gentoo-ea65382a8442c9c9a909d05f783080a5a88fa1db.tar.bz2
gentoo-ea65382a8442c9c9a909d05f783080a5a88fa1db.zip
dev-python/testresources: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/testresources/testresources-0.2.7-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/testresources/testresources-0.2.7-r3.ebuild b/dev-python/testresources/testresources-0.2.7-r3.ebuild
new file mode 100644
index 000000000000..c5333a451354
--- /dev/null
+++ b/dev-python/testresources/testresources-0.2.7-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A pyunit extension for managing expensive test resources"
+HOMEPAGE="https://launchpad.net/testresources"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}